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1 INTRODUCTION

Verifone C-Site Management is a web application that enables Petroleum Merchants and Major Oil 
administrators to maintain a centralized point for site data, monitor sites remotely, and provides a 
convenient platform for synchronous oversight and configuration. 

Verifone C-Site Management does not require a technician to visit each location to make changes and 
updates. Updates can be done selectively or all at once from the web application.

This guide covers the following topics:

• Hierarchy: Setting up and managing hierarchy, the arrangement of groups and sites to reflect the 
business structure (e.g. National > Regional > Western > Pacific).

• Sites: Setting up and managing sites (individual business locations) within the hierarchy.

• User Administration: Creating and managing users with various roles and permissions (e.g. access to 
administrative or reporting features within the C-Site Management application)

• Dashboard: An overview of the application's dashboard, from which the features can be accessed, view 
configuration steps (and their completion status), and find information on additional help and support.

• My Account: Information for users on viewing their account information. Editing user information is not 
available currently.

• Reports: Reporting allows near-real-time data for Transaction Logs (T-Logs), Site Assets, and Summary 
details to be readily viewed. 

• Configuration: Remotely manage and synchronize site configurations for Password Management, 
Primary Payment, Mobile Payment, Loyalty Configuration, Viper Card Tables, and various site price book 
configurations.

• Connect Device to Cloud: This feature allows the connection to the Verifone Commander to the 
Verifone C-Site Management cloud application.

• One-Time Password: This feature allows the One-Time Password (OTP) to be sent from the Verifone 
Commander to an email address to access the OTP-dependent features of the Verifone Commander.
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System Requirements

Software Requirements

• Verifone Software Release: Support begins in 53.35+

• Web Browser: Microsoft Edge, Chrome, Firefox, or Safari accessed through a computer.

Software Release Specific Implementation

 

WARNING

If the Verifone Commander is not onboarded to the Verifone C-Site Management 
within a certain amount of time, it will not be able to perform merchandise and fuel 
transactions.
See the Appendix I section for specific details.
In release 55.01, the requirement to onboard onto C-Site Management still exists, 
but merchandise and fuel functionality will not be disabled.

Release Features Supported

53.35 T-Log Viewer, Site Assets, OTP

53.41 Mobile Payment Configuration, Viper Table Set Management

54.00 Loyalty Configuration

54.01 POS Configuration, Commander Configuration Acknowledgment

54.02 POS Security, Fuel Tax Exemptions, Enhanced C-Site Onboarding Support, Major oil accounts can 
use loyalty configuration from C-Site Management

55.00 PLUs, Sales Configuration, Login/Logout Message, Fuel Pricing - Pending, Fuel Configuration - In 
Effect

55.01 Dealer Location ID Presented in Site Asset Report

55.02 Caloric Values, DCR Configuration, Primary Payment Configuration

56.00 Menu Configuration (Read Only), and Touch Screen Configuration

56.01 Tipping, Verifone Commander Password Management, Replicate Configuration
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56.02 External Access Menu under Administration for approving VASC Access and Partner Access, Image 
Upload, Editable Menu Configuration, Major Oil Policy, Commercial Fleet Direct, and User Site 
Assignments.

56.03 New Site Configuration forms: Store Operations > House Accounts, Store Operations > Charity 
Donations, Promos and Discounts > Car Wash PLU Promotions, and Forecourt > Fuel Display.

Release Features Supported
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Version Support Notification

C-Site Management has been enhanced to display when the connected site's software release version 
does not support specific forms. Messaging will appear that states 'This Version (xxx.xx.xx) does not 
support configuring the form, please upgrade your Commander.' 

Software upgrades can be requested through Verifone's Remote Software Delivery (VRSD) process. See 
the VRSD Implementation Guide for more details. 

Hardware Requirements

• Verifone Commander with supported POS

• Computer (Desktop or Laptop) with the most recent security updates

• Managed Network Service Provider (MNSP) Implemented 

• Broadband Internet Connection

Account Sign Up
1. To create an account for Verifone C-Site Management, navigate to the following URL and select 'Sign 

Up for Free'. 

https://petromop.verifone.cloud/home
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2. Complete and submit the form presented. 

  

NOTE If the administrator has more than one store, only one account is needed. 
All sites should be onboarded to one account.
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Terms and Conditions

When logging into Verifone C-Site Management, a prompt appears to accept the terms and conditions. To 
log into the application, accept the terms and conditions to proceed.

To view the Terms and Conditions, select the blue text in the prompt.

At anytime, the Terms and Conditions can be reviewed by clicking on the profile icon in the upper right-hand 
corner of the screen and selecting “Terms” from the menu. 
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Website URL 
To access Verifone C-Site Management, navigate to the following URL using a web browser:

https://us.live.verifone.cloud/
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2 HIERARCHY

This section provides an overview of how to edit and manipulate hierarchies on the Merchant 
Administration page. A hierarchy structure allows the building or mapping of the business structure within 
Verifone C-Site Management. Hierarchies should be set up before adding sites to Verifone C-Site 
Management. This allows more effective use of the Bulk Site Upload feature.

View Hierarchy
1. Log into the Verifone C-Site Management application.

2. Click on Administration > Site Management > Hierarchy. 

3. Use the Search bar to search for the name or use the collapsible menu below the search bar.
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Edit Hierarchy

1. Hierarchies can be edited by selected the Edit Hierarchy button in the top right corner of the Hierarchy 
window.

2. The following icons will appear next to the hierarchy names. Not all icons will appear next to each name 
based on the available functions for that row.

  

NOTE If a new Merchant Administrator has not set up any hierarchy for the account, the display 
page will show the company name with any sub-entries all in one group.
                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         10



                                                                                                                                Verifone C-Site Management User Guide
 

Icon Description

Edits an existing groups name.

Adds a sub-group to an existing group.

Reorders icons by selecting the group to move from the list, and then dragging and dropping the 
group.

Adds a new group to the highlighted row. The new group name prompt will appear below this line 
when selecting this icon. 

Deletes a group
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Search
Key in the name of the group in the search field to narrow down the hierarchy to the entered characters.
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3 SITES

Sites (stores) are the individual C-store/gas station at which the Verifone Commander resides. The Verifone 
Commander at each location must be setup to communicate to the Verifone C-Site Management system in 
addition to being provisioned through Verifone C-Site Management. Those details are discussed in the 
Connect Device to Cloud section. This section will discuss how to add or onboard sites to the 
Verifone C-Site Management system individually or in bulk.

Commander (Service ID) Transfer Between Merchant Accounts

Validation During Onboarding

Verifone C-Site Management verifies that the provided serial number and Service ID are valid and not 
currently associated with any active merchant account. If the Verifone Commander is still onboarded to 
another merchant, an error will display stating that a Verifone C-Site Management account exists for the 
Verifone Commander. The original merchant must remove the Verifone Commander by deleting the site 
from their account before is can be added to a new account.

Software Distribution Requirements

If the new merchant obtains a Verifone Commander with an existing software distribution installed, the 
Verifone Commander must be reloaded with a new software installation and then onboarded. (Also, the 
Verifone Commander must be removed from the original merchant account before onboarding to a new 
account.) Provisioning the new site/Verifone Commander in the new account is optional, but removal from 
the original account is mandatory.

Major Oil Account Automation

For merchants associated with Major Oil, Verifone C-Site Management automates the transition. After the 
Verifone Commander is onboarded to the new merchant account, Verifone C-Site Management 
automatically removes it from the previous Major Oil account and adds it to the new one. If the Major Oil 
affiliation remains the same, no changes are made.

  

NOTE
If the previous merchant cannot be located to delete the account, call the Verifone 
Helpdesk.
In most cases, the Verifone Commander Service ID remains the same, only the Merchant ID 
changes. 
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Required Site Information
The following information must be obtained from the sites you wish to onboard to Verifone C-Site 
management:

• Verifone Service ID as shown in the site’s contract.

• Site’s Name

• Site’s Address

• Site’s Phone number

View Hierarchy
1. Log in to the Verifone C-Site Management application.

2. Click on Administration > Site Management > Hierarchy. 

3. Use the Search bar to search for the name or use the collapsible menu below the search bar.

  

NOTE
Before the site is onboarded, make sure the hierarchies are set up correctly.   
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Bulk Site Creation
Bulk site creation is used to onboard up to 2,000 sites to Verifone’s C-Site Management rather than one site 
at a time. This feature utilizes an Excel Spreadsheet where site information such as service ID, address, and 
hierarchy assignment are entered in a spreadsheet and then uploaded to the cloud. The data entered is 
checked for validity after it is uploaded to the cloud and a Bulk Upload Report is generated to provide 
information on whether the site creation was successful.

Downloading the Template

1. Navigate to Administration > Site Management > Sites.

2. Select Create Site in the top right corner of the menu.

3. Select Create in Bulk.
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4. Click on Downloading Excel Template File.

5. Download the Excel document titled ‘Petro_Cloud_Template.xlsx’. When you open the document, you 
may need to Enable Editing depending upon your Microsoft Excel version.
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6. Enter in the site information, one site per row. All fields that have an asterisk (*) are required. After all 
the entries are completed, save the changes made to the spreadsheet.

7. Return to the Template Download page on Verifone C-Site Management and select Continue at the 
bottom of the page. 

Field Description

Service ID* The Verifone Service ID shown in the site’s contract with Verifone.

Site ID Any ID number used by the organization operating the site.

Site Name* The name of the site. This is useful when searching for sites. You must enter a site name and it must 
be unique to the site.

Sub Groups* Assign a site to a location in the hierarchy using the Sub Groups. The hierarchy subgroups must 
exist before the bulk upload, or the site will be added to the root company.

Street Address* The physical address of the site.

City* The municipality in which the site is located (or equivalent).

Zip Code* The ZIP code for the site.

State* Choose a state from the drop-down list.

Custom Attributes You can create your own attributes for sorting and filtering sites. See below for more information.

 

WARNING A valid Verifone Service ID MUST be entered. If the entry is incorrect the site will not 
be onboarded.
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8. Drag and drop the Petro Cloud Template Spread sheet in the dotted area or Browse files and locate the 
file to upload. 

9. After the file is ready to transfer, the ‘Drag and drop XLS file here’ will update to the name of the file 
selected. Click Continue to upload the file.

10. The Done screen will appear. A transaction ID for the upload will be generated for your reference. From 
here, you can select reports page on the screen to view the Bulk Upload Report, or you can navigate to 
View Sites.
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Bulk Upload Report

After a bulk site upload is completed, a Bulk Upload report is generated to provide details on which sites 
were successfully added to Verifone C-Site Management. 

The report can be accessed by selecting the ‘reports page’ text in blue (shown above) or by navigating to 
Administration > Site Management > Bulk Upload Report. Each Bulk Upload performed has a Transaction 
ID generated, allowing you to review the specific Transaction ID in the reports list.

A status is generated to let you know if there was an Error in the upload, or if the upload completed 
successfully. Since multiple sites can be uploaded at the same time, an Error response will appear even if 
there is only one site that had an issue. If all sites upload without any errors, the Status will show a green 
Success.

Bulk Upload Report Errors

The following errors may occur during upload. Utilize the table below to resolve any errors that occurred 
during the upload. Be sure to select the Transaction ID associated with the upload. 

Error Description Resolution

Mandatory Fields 
Required

If any mandatory fields are missing (Service ID, 
Site Name, Address Line 1, Country, State, City, 
or Zip code).

Confirm that the information is present in the 
mandatory fields and upload the site again.

Invalid Service ID 
Range

If the Service ID Length is less than 7-Digits. Confirm the Service ID entered is 7-Digits.

Service ID Not Found Service ID Not found in CRM Database. Confirm the Service ID is a valid Service ID.

Site Created 
Successfully

Site Created Successfully. Upload completed without any errors. 

Invalid Attribute. Site 
Created Successfully

Site created successfully and an invalid 
attribute was found.

The site was added to the Sites list, but an 
attribute was invalid. Make corrections to the 
site on the Administration > Sites page.

Invalid Subgroup 
Combination Found. 
Invalid Attribute. Site 
Created Successfully

Site created successfully but has an invalid 
subgroup name and attribute combination.

An invalid attribute and subgroups (hierarchy 
assignment) were found in the uploaded 
document. Make corrections to the site on the 
Administration > Sites page.
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Invalid subgroup 
combination found. 
Site Created 
Successfully

Site created successfully but subgroup 
combination is incorrect.

The subgroups (hierarchy assignment) was 
invalid in the uploaded document. Make 
corrections to the site on the Administration > 
Sites page.

Site Name Already 
Exists

The site name already exist in sites table. Either change the existing site record’s name or 
change the site name in the upload document. 
The site will need to be added again after 
changes are made.

Duplicate Service ID 
and Site Name

A duplicate Service ID and Site Name 
combination found in the upload document.

Remove the duplicate records and upload the 
site again.

Duplicate Service ID A duplicate Service ID was found in the upload 
document.

Remove the duplicate service ID and upload 
the site again.

Duplicate Site Name A duplicate site name combination was found 
in the upload document.

Remove the duplicate site name and upload 
the site again.

Site: Entity Service 
Error

Site entity service failure. Attempt the upload again. 

Address: Entity 
Service Error

Address entity service failure. Attempt the upload again. 

Mandatory Fields 
Required

If any mandatory fields are missing (Service ID, 
Site Name, Address Line 1, Country, State, City, 
or ZIP code).

Confirm that the information is present in the 
mandatory fields and upload the site again.

Invalid Service ID 
Range

If the Service ID Length is less than 7-Digits. Confirm the Service ID entered is 7-Digits.

Error Description Resolution
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Manual Site Creation
Manual creation is intended to be used to add one site at a time. To add multiple sites, use Bulk Site 
Creation. Manual creation utilizes a web form to fill in the required site details to onboard the site to Verifone 
C-Site Management System.

1. Navigate to Administration > Site Management > Sites.

2. Select Create Site in the top right corner of the menu.

3. Select Create Manually under the Manual Creation section.
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4. Complete the Site Details form. Service ID, Site Name, Address Line 1, Country, State, City, and ZIP Code 
are required (*) fields.

   

5. After filling in the fields is completed, click Create Site to add the new site or Discard to return to the 
Sites window.

Field Definition

Service ID* The Verifone Service ID shown in the 
site’s contract with Verifone.

Site ID Any ID number used by the 
organization operating the site.

Site Name* The name of the site. This is useful 
when searching for sites. You must 
enter a site name.

Custom 
Attributes

You can create your own attributes 
for sorting and filtering sites. See 
below for more information.

Street 
Address*

The physical address of the site.

City* The municipality in which the site is 
located (or equivalent).

Zip Code* The ZIP code for the site.

State* Choose a state from the drop-down 
list.

Hierarchy* Assign a site to a location in the 
hierarchy using this feature, by 
navigating to the correct location in 
the hierarchy, clicking on it, and then 
clicking “Re-assign site.”
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Adding Custom Attributes
Custom attributes allow users to search for sites based on specific criteria relevant to those sites, such as 
brand of fuel sold, software version on the site controller, type of installation, etc. Up to five attributes can 
be added per site.

1. Select the + Add custom attributes within the create site form under the Manual Site Creation form.

2. Enter the name for the attribute in the field that appears.

3. Enter a value in the field provided.

4. To delete an attribute, select the Trash can icon.

5. When selecting Create Site, the custom attributes will be added along with the rest of the site data.
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Editing Existing Sites
1. To edit a site, select the site from the site list. 

2. In the top right corner of the screen, select Edit Site.

3. Changes can be saved (Save Changes) or Discarded (Discard). The site can also be deleted by selecting 
Delete Site on the bottom left corner.

  

NOTE To re-assign a site's hierarchy, select the 'Re-Assign Site' button on the Site Details page 
(before selecting the Edit Site button).
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4 ROLES

The Roles feature is used to assign different permissions and features to a single or multiple users. It can 
restrict users or groups of users from accessing various features. 

To navigate to Roles, select Administration > User Management > Roles.

  

NOTE Verifone will configure default role permissions for the application. Administrator users will 
need to create roles using the permissions, and then assign them to users.     
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Adding User Roles
1. To add user roles, navigate to Administration > User Management > Roles and select Add Role at the 

top of the page.

2. Complete the form by entering at least a role name and selecting appropriate permissions. Use the table 
below for more details.

Field Description

Role Name A name to easily identify the role that is unique and accurately describes the permissions assigned to 
the user. Ex. Store Manager, Pricebook Manager, Accounting

Role Description An optional field where you can describe the roles’ purpose and function.

Status Allows the role to be enabled to deactivated.

Copy Permission from 
role

Clones all permissions from one user role to another. Useful if you want to then add or remove a single 
item.

Administration Site Management: Allows the user to access the Sites features under the Administration menu. (For 
more information, see the Site Management section.)

Roles Management: Allows the user to access the User Roles functions.

User Management: Allows the user to access the Users functions under the Administration menu. 
(For more information, see the User Management section.)

Configuration Store Operations: Allows the user to access site specific configurations related to store operations 
such as MOP, Tax rates, Departments, Access Control, Fuel Prices, Fuel Configuration, etc.

Payment Operations Configuration: Allows the user to edit and/or access Primary Payment, Mobile 
Payment & Loyalty Programs and site-specific configurations (For more information see the Primary 
Payment, Mobile Payment, and Loyalty sections.)
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Reports Site Assets: Allows the user to run Site Asset reports.

TLog: Allows the user to run Transaction Log reports.

Summary Report: Allows the user to run Summary Reports.
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5 ACCOUNT TYPES AND FEATURES

Currently, Verifone C-Site Management is designed to support a diverse set of users, each with specific 
responsibilities and access levels. Below is an introduction to the four primary account types:

• Merchant - They are the C-Site owners or operators for managing the daily operations of a gas 
station. 

• Major Oil - They sell fuel products under well-known names. Branded gas stations are C-Sites that 
operate under the branding of these major oil companies. 

• VASC - They are the Verifone Authorized Service Contractors that have received a certification 
through Verifone’s training course. They are responsible for setting up, configuring, and ensuring 
proper operation of Verifone’s POS equipment. 

• Partner - They develop complimentary products or solutions that are designed to connect with, 
extend, or enhance the Verifone POS equipment. These partnerships are built on shared standards, 
APIs, or certifications to guarantee reliability and performance. 
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The following table organizes accessible features by mapping them to the above four account types for 
visibility and comparison. 

*Requires merchant administrator authorization.

Feature Merchant Major Oil VASC Partner

Site Provision Yes Yes No No

Hierarchy Yes Yes Yes Yes

Site Onboarding Yes No Yes* No

Site Assets Data Yes Yes No No

Transaction Data Yes No No No

Transaction Data though API No No No Yes*

Loyalty and Mobile Configuration Yes Yes No No

POS and Forecourt Configuration Yes No No No

Payment Configuration Yes Yes No No

VIPER (EPS) Table Management Yes Yes No No

Major Oil Policy No Yes No No

Verifone Commander Generated OTP Yes No No No
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6 CREATE USERS

Create User

1. To create new users, navigate to Administration > User Management > Users. 

2. Click Add User in the top right corner of the screen. 

  

NOTE
Before creating users, Hierarchies, Sites, and User Roles must already be configured.        
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3. Complete the required fields using the table below the screenshot for reference and then click on 
Create User.
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Automatic Site Assignment
When an administrator places a new Site or Verifone Commander into a subtree within the hierarchy that is 
already fully assigned to one or more users, the system will now automatically assign those users to the 
new Site/Verifone Commander.

Previously, administrators were required to manually assign each site to individual user accounts.

Field Description

Name Enter in the name of the user. It is recommended to use the First and Last name in the name field. 

Email Enter in the email address for the user. It is recommended to use company email addresses when 
possible. The email address is used for logging into the Verifone C-Site application.

Status Users can be set to active or deactivated if they no longer need access to the Verifone C-Site 
Application.

Role Assign the role from the list that best fits the users job functions. See the Roles section for more detail 
on roles and role permissions.

Site Assignments Users can be assigned to specific hierarchies, meaning they can be permitted access to only a subset 
of sites. If the user requires access to all sites, then select the first option under site assignments 
which will select all locations.
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Deleting a User
1. To delete users, navigate to Administration > User Management > Users. 

2. Select the user from the list.
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3. Select Delete User on the bottom left corner of the User Detail screen. To utilize the same email 
address, the Verifone Helpdesk must be contacted to fully remove the users email address.
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Creating an Additional Administrator Account
Only one site administrator exists when the account is created initially. If you need to create additional users 
with the same access level then the user’s role will need to be modified. 

1. Login with the current Petro Site Administrator account.

2. Navigate to the newly created or existing user and select them from the user list under Administration > 
User Management > Users.
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3. After the user is selected, click Edit User from the top right corner. 
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4. Update the user’s role to Petro Site Admin from the Role drop-down menu. 

5. Click Save Changes.
                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         38



 

7 DASHBOARD

This section discusses the Verifone C-Site Management application Dashboard. The dashboard provides 
information on active sites, offline sites, latest sites added, pending authorization sites, and devices.

The Dashboard is located under C-Site Management > Overview > Dashboard.

  

NOTE Not all users will have access to all these features. Feature access will depend on a user’s 
permissions. See the User Role and Users sections for more information.        
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Dashboard on Initial Login
Here is a sample dashboard layout with some steps already completed. You should work through each 
step-in sequence to properly configure the application. See the Hierarchy, Sites, Roles, and Users sections 
of the documentation for information on configuring each of these areas.

1. Hierarchy: Add and view hierarchies, which are lists of groups of sites as your business organizes them, 
e.g., National > Regional > State, etc.

2. Sites: Create and manipulate lists of sites that sit in various levels of the hierarchy.

3. Roles: Create user roles so you can assign permissions (configured by Verifone) to individual users or 
groups of users at one time.

4. Users: Create and manage user profiles for users who need to log in to perform various functions in the 
Cloud application.
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After you have completed all the setup steps, and have active Sites, the Dashboard will look like this:
                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         41



                                                                                                                                Verifone C-Site Management User Guide
 

                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         42



 

8 MY ACCOUNT

The My Account section allows you to view and edit details regarding to your specific user account 
including your name, language, and password.

To view your account information, click on the profile icon in the top right corner of the Verifone C-Site 
Management web page after logging in. Select My Account from the drop down. 
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The first page will display the account’s General Information. To make any changes select the Edit User 
button in the lower right corner. 

Field Description

First name, Middle 
name, Last name

Displays the users First, Middle (Optional), and Last (Optional) Name. 

Note: For some users the First Name may display the users email address or their first and last name. 
This can be updated in Edit User.

Organization Displays the organizations (company) name to which the user belongs.

Organization ID Displays the Organization ID assigned to the company. This is a unique ID that is specific to the 
organization.

Email Displays the user’s email address.

Phone Number Displays the user’s phone number. 

Roles Displays all user roles assigned to the user. Role assignments cannot be changed in My Account. 
They are changed under Administration > Users.

Status Displays if the account is enabled or disabled.
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Changing Password
1. To change your password, login with your current username and password. 

2. Select the profile icon in the top right corner of the Verifone C-Site Management website and choose 
My Account.

3. Select the Edit user button under the General Information section.

4. Towards the bottom of the page select the Change password button. 

5. Enter in the current password in the first field. Type in the new password in the new password and 
Confirm new Password fields. Select Update to apply the new password. 

• Passwords must be at least eight characters long and contain at least 1 number, at least one capital 
letter, at least one lowercase letter, and at least 1 symbol. 

• Passwords must be different from the users last 10 passwords.

Forgot Password
In the event a user has forgotten their password, there is a Forgot Password option at the login screen of 
Verifone C-Site Management.

1. To reset your password, enter your email and select the submit button. After the email has been sent, 
the user can no longer log in with their previous password. The user must reset their password following 
the email instructions.
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2. After the password has been reset, the user must log in with the new password.
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9 REPORTS

There are three different reporting options currently available within Verifone C-Site Management: Site 
Assets, Tlog Viewer, & Summary Report. Reports are located under Commerce > Petro Reports.

Site Asset Reports
The site asset report provides an overview of all devices connected to the Commander at the onboarded 
locations. To locate the Site Asset Report, select Commerce > Site Assets.
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Search Functions in Site Asset Reports

To search by Service ID, enter 
the Service ID in the search field 
and click Search.

To search by Site ID or 
Location ID, click the Service ID 
drop down and change the 
selection. Location ID 
information is only available in 
release versions 55.01+.

To search by name within the 
Hierarchy, click the Hierarchy 
button and enter the name for 
which you wish to search, and 
click Apply.

To filter results by item in the hierarchy, click the Hierarchy button and 
use the checkboxes to select items (i.e., Florida and California in the 
screenshot below). When you have configured your search, click Apply.

The search results will appear on the Site Assets Report page.

  

NOTE The items that appear beside the check boxes under the filter criteria buttons (e.g., 
Commander, Register, Car Wash in the screenshot above) depend on the equipment that is 
present at the site(s) you are including in the report.       
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Reports can be filtered using the following criteria:

Download Site Asset Report

The information shown can be downloaded in a .csv file format and saved to the local computer. If the 
information is filtered/searched, then the report download will populate with the displayed information. 

Selecting Download Report on the Site Assets main page will prompt for the report to be downloaded.

Field Description

Devices Displays the device type such as Dispenser, Register, Commander, PIN Pad, Other, DCR, etc.

Vendor Displays the Vendor of the product when applicable. For example, dispensers will show the dispenser 
brand name when that information is available. Click + Add filter to see this option.

Model Displays model information available (e.g., Commander > Ruby Ci)

Software Searches from the specific software for the device. For Commander software, this area displays the 
Release version of the software. For PIN pads it will display the entire software name and version.

Suite Version Displays the specific Commander application version and green box version when applicable. Click + 
Add filter to see this option. 

Hierarchy Allows for the search information to narrow down locations based on their hierarchy organization. 
Multiple or individual sites can be selected using this option.
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Tlog Viewer
The Tlog viewer feature allows for financial transaction logs or transaction journal entries to be viewed from 
Verifone C-Site Management. Only the last 7-days of Tlogs are available for review.

To locate the Site Asset Report, select Commerce > Tlog Viewer.

Search Functions in Tlog Viewer

The Tlog viewer search requires a service ID or a site (one) selected from the Hierarchy drop down to 
perform a search.

  

NOTE
This feature is only available to Merchants and Retailers.       

Field Description

Service ID (Default) Select Service ID from the drop-down menu to the left of the search criteria text box and 
enter the site’s service ID.

Date: Predefined Choose from Today, Yesterday, or up to the last 7 Days.

Date: Custom Select a date using the calendar controls. You can only select the last 7 days.

Type Use the check boxes to select Financial and/or Journal entries. Financial is selected by default but can 
be changed by selecting the Type drop down. 

Hierarchy Use the check boxes to select Site Names from the Hierarchies configured within C-Site.

Add Filter: Trans Types Use the check boxes to select from the transaction types configured on the system.
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Download Site Asset Report

The information shown can be downloaded in a .csv file format and saved to the local computer. If the 
information is filtered/searched, then the report download will populate with the displayed information. 

Selecting Download Report on the Tlog Viewer page will prompt for the report to be downloaded.

Add Filter: Journal 
Types

Use the check boxes to select from the journal entry types configured on the system.

Results per Page Select how many entries you wish to view at a time (Default is 10).

  

NOTE Click on the record to view the transaction details. Details will vary based on the 
transaction type selected. Transaction logs will never display full card numbers.       
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Summary Report
The Summary Report provides data about merchandise sales by category and fuel sales. To access the 
summary report in Verifone C-Site Management go to Commerce > Summary Report.

To view the summary report, a date and location must be selected. Location can be located by using the 
Service ID or the Hierarchy selection. Select the date and sequence number result to view the summary 
report details.

  

NOTE
This feature is only available to Retail administrators and their users.      

  

NOTE Only one date can be selected at a time. Reports are archived within Verifone C-Site 
Management and accessible for only one week. The week is based on a calendar week 
and not the site's day close.    
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Summary Report Details

Field Description

Site Information Shown in the top row. From here, you can click See Site Info to view the site’s information, but this 

will exit the report and you will have to generate it again.

Period Open/Close Shows the date selected for the report.

Merchandise Sales

Category Shows the Category number for the transactions.

Description Shows the category description for the transactions. This is configured in the POS system itself. 

Sales Shows the sale amount for each transaction.

Void Amount Shows the dollar amount on sales cancelled by the cashier.

Void Count Shows the number of cancelled sales.

Overall Total This row shows the totals for each column for every transaction in the period.

Fuel Sales

Fuel Cnt Shows the total number of fuel sales transactions.

Fuel Amt Shows the dollar amount of fuel sales.

Fuel Gallons Shows the number of gallons of fuel sold per transaction.

Void Fuel Cnt Shows the total number of fuel sales cancelled by the cashier.

Void Fuel Amt Shows the dollar amount of cancelled fuel sales.

Drive Off Cnt Shows the number of fuel sale transactions that were not paid for.

Drive Off Amt Shows the total dollar amount from unpaid-for fuel sale transactions.
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10 PASSWORD MANAGEMENT (ENTERPRISE)

Enterprise Password Management in Verifone C-Site Management allows for password settings to be 
configured and managed in the cloud, and then transmitted to a single or multiple Verifone Commanders. 
Support for password remote management within the Verifone C-Site Management application requires 
software Release 56.01 or higher.

Configuration Syncing

Initial Onboarding

When the Verifone Commander is initially onboarded into the cloud, if it is on Release 56.01 or higher, it will 
transmit its current password management to the Verifone C-Site Management application. 

The current password management is only transmitted to the Verifone C-Site Management application 
during the initial onboarding. 

Configuration Updates

• After the initial upload of the current configuration, any updates made in Verifone C-Site 
Management can be accessed and transferred to the site by either the major oil provider and/or the 
merchant administrator (if applicable.) 

• After the site is onboarded to the cloud, User Administration will still be available within Verifone 
Configuration Client.

• If there are local changes within Verifone Configuration Client made to the User Administration at the 
site, these changes will NOT be transmitted to Verifone C-Site Management. 

• If updates are sent to the site from Verifone C-Site Management, the last update sent will override 
previously transmitted or locally stored data.

 

NOTE
Password Management requires Verifone Commander 56.01 release version.      
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Password Management
Managing passwords in Verifone C-Site Management involves securely storing and accessing passwords 
from single or multiple Verifone Commanders. This is done using Password Management.

Manage Passwords

1. To manage passwords, navigate to C-Site Management > Configuration > Site Management and 
select the Sites drop-down menu and switch the view to Enterprise. 

2. After navigating to the Enterprise view, select Filter in the middle of the screen.
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3. Select Commander User Management from the Configuration Category drop-down menu.

4. Select Password Management from the Configuration Type drop-down menu. 

5. Click Filter to view Password Management. 

6. Click Manage Password to select and edit a password at one or more Verifone Commanders. 
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7. Key in the Commander User Name for the selected site(s).

8. Key in the new password using the Password Guidelines on the right side of the form. 

9. Key in the new password again to confirm.

10. Search or select the sites for the new password.

11. Click on Validate to make sure Commander User Name is correct and the new password meets the 
criteria OR click Discard to remove changes.
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12. If the Password Validation is successful, click Apply Changes OR Back to correct the entries.

 

13. After the new password is applied, Download Report if needed. The sites can be filtered on the Manager 
Report Details by clicking on the column headers.
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Password Creation Errors

If the new password does not meet the guidelines and the Verifone Commander rejects it, an error will 
display. 
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If the username does not match the configuration in Verifone Commander, an error will display.
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11 LOYALTY (ENTERPRISE)

Loyalty Configuration in Verifone C-Site Management allows for Loyalty settings to be configured and 
managed in the cloud, and then transmitted to a single or multiple sites. Support Loyalty remote 
management within the Verifone C-Site Management application requires software Release 54.00 or 
higher.

Configuration Syncing

Initial Onboarding

When the Verifone Commander is initially onboarded into the cloud, if it is on Release 54.00 or higher, it will 
transmit its current Loyalty configuration to the Verifone C-Site Management application. 

The current configuration is only transmitted to the Verifone C-Site Management application during the 
initial onboarding. 

Configuration Updates

• After the initial upload of the current configuration, any updates made in Verifone C-Site 
Management can be accessed and transferred to the site by either the major oil provider and/or the 
merchant administrator (if applicable.) 

• After the site is onboarded to the cloud, Loyalty Configuration will still be available within Verifone 
Configuration Client.

• If there are local changes within Verifone Configuration Client made to the Loyalty Payment 
Configuration at the site, these changes will NOT be transmitted to Verifone C-Site Management. 

• If updates are sent to the site from Verifone C-Site Management, the last update sent will override 
previously transmitted or locally stored data.

Loyalty Programs
The loyalty payment program allows for different loyalty programs to be generated and assigned to multiple 
sites with specific Merchant IDs (MIDs) for each location. Loyalty Programs can be created in Verifone 
C-Site Management, or they can be added when the site is onboarded to Verifone C-Site Management. 
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Create Program

1. To create a new Loyalty program, navigate to C-Site Management > Configuration > Site Management 
> Select the Sites drop down and switch the view to Enterprise. 

2. After navigating to the Enterprise view, select + Create New in the top right corner. 

3. From the Create New Data Set pop-up, select the Configuration Category of Payment Operations. 
Select the Configuration Type of Loyalty.
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4. Click Continue to open the creation form.

5. Complete the following parameters shown specific to the Loyalty Program being configured. See table 
below for details on each field.
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6. Select Save & Next to save the parameters entered.

Field Description

Create New or 

Clone from Existing

To create a new loyalty program, select the Create New bullet.

To copy settings from another loyalty program to be modified, select Clone from existing. (See next 
section for more details)

Configuration Name The specific name for the loyalty provider.

Provider Select the loyalty provider from the list that is used to host the name. The list is a pre-defined 
selection of approved loyalty hosts.

Program Name Sets the Program ID for the loyalty program.

IP/Host Sets the IP address of the loyalty host. (Provided by loyalty host)

Port Communication Port Number for the primary loyalty host (Provided by loyalty host)

Heartbeat (seconds) Sets the interval in seconds between network status checks from the Electronic Payment Server to 
the Loyalty Host. Minimum amount allowed is 120 seconds.

Enable TLS Enables the use of secure Transport Layer Security (TLS) connection to the loyalty host. When TLS is 
used, data is encrypted over the communication line. 

Program Settings Enable Bar code Scan - Enables bar code scanning for the related FEP.

Display FEP inside for Multiple Loyalty -Displays loyalty programs at the POS when multiple loyalty is 
used.

Enable Card Download - Allows the loyalty host to send down loyalty cards through the Loyalty Card 
Table Download function. 

Display FEP Outside for Multiple Loyalty - Displays the Loyalty Program at the DCR when multiple 
loyalty is used.

Receipt Offline 
Message

When loyalty is offline the message entered here will print on the receipt.
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Clone from Existing Program

1. If the Clone from Existing Program is selected on the Create Program form, it will prompt to search for 
the name of the program to clone. 

2. After completing the search function, select clone or view from the return list displayed. 

3. Enter in the Configuration Name and Program Name for the configuration. Make any additional changes 
to the communication parameters and program settings before continuing. See the table above for 
more details on each field.
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Add Loyalty Cards

1. The next section on the Create Program form allows loyalty cards to be added to the program. 

2. If an Alternate ID is allowed with the loyalty card, select the check mark next to ‘Add Alternate ID’. An Alt 
ID Card name will be automatically added to the table. Alternate ID cannot be edited, it is only enabled 
by being added to the card table. 

3. Select ‘Add Another Card’ to add additional loyalty cards to the list.  

4. Complete the entry fields for the specific loyalty card being used. 

Field Description

Card Disabled Disables the loyalty card.

Card Abbreviation Two-character abbreviation for the card.

Lower Iso Sets the lower value of the card bin range. The entered card number must be greater than or equal to 
this number to match the table entry.

For standard bar codes and mag stripe loyalty cards this will be the first six-digits.

For GS-128 bar codes, ‘8018’ is a special application ID and is required as the first four-digits of the 
Lower ISO range followed by the first two-digits of the bar code.

Upper Iso Sets the upper value of the card bin range. The entered card number must be less than or equal this 
number to match the table entry. 

For standard bar codes, GS-128 bar codes, and mag stripe this will be the same as the lower ISO 
range or ending range value.

Pan Length Sets the number of digits that are used with each card or barcode. 

Mag-stripe loyalty cards use 16-digits. Standard bar codes used 12-digits. GS-128 bar codes use 
22-digits. 
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5. Select Save in the Card window to save the card. Add any additional cards needed for the specific 
loyalty program.

6. Select Save & Next to proceed to the Site Assignment Area.

Site Assignment

The site assignment section displays a list of sites that have been onboarded to your C-Site Management 
account. 

1. Select the sites this loyalty should apply to from the list. Selecting the top level of a group will select all 
sites within that group. 

2. Select Save & Next after the sites are selected.
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Loyalty Merchant ID (MID)

Each location must have a merchant ID (MID) assigned to it for the loyalty provider. The MID allows the 
loyalty host to identify the site for transactions. Every location will have a unique MID.

Enter in the Merchant ID to the right of each selected location. Be sure to enter in the correct MID for each 
site as it is the loyalty provider’s unique identifier for the site. 

There is an optional Bulk Upload feature that allows a spreadsheet to be utilized to import multiple MIDs at 
one time. 

To complete a Bulk Upload for Loyalty MIDs, select the Bulk Upload button on the form, export the template, 
complete the form, and upload the file to the MID section.
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Review the Parameters

Before applying the parameters, you can review the selections and entries made to confirm they are 
correct. At the bottom of the form, the Card(s) and Site(s) Assignment are collapsed. To expand those 
sections, click the title to expand or collapse those sections.

Click Save & Next to apply the configuration.
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View Existing Loyalty Programs

1. To create a new Loyalty program, navigate to C-Site Management > Site Management > Select the 
Sites drop down and switch the view to Enterprise. 

2. Check the Viewing selection to the right of the filter button. If it is set to Viewing: Loyalty, then use the 
Filter function to switch to Loyalty (Configuration Category: Payment Operations | Configuration Type: 
Loyalty). 

3. All loyalty programs will be displayed. To search for a specific loyalty configuration, use the drop down 
to the left of the search criteria bar to switch between loyalty provider, configuration name, or program 
name.

4. Select the three dots to the right of the Program Name view. 

5. Click View.
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12 MOBILE PAYMENT (ENTERPRISE)

Mobile Payment Configuration in Verifone C-Site Management allows for Mobile Payment settings to be 
configured and managed in the cloud, and then transmitted to a single or multiple sites. Support Mobile 
Payment remote management within the Verifone C-Site Management application requires software 
Release 53.41 or higher.

Mobile Payment Configuration in Verifone C-Site Management does NOT set up the Method of Payment 
(MOP), touchscreen, and DCRs. For details on how to configure Mobile Payments locally within Verifone 
Configuration Client see the Mobile Payment Feature Reference guide.

Configuration Syncing

Initial Onboarding

• When the Verifone Commander is initially onboarded into the cloud, if it is on Release 53.41 or higher, 
it will transmit its current Mobile Payment configuration to the Verifone C-Site Management 
application. 

• The current configuration is only transmitted to the Verifone C-Site Management application during 
the initial onboarding. If the Program Name does not exist, then the Verifone C-Site Management 
application will create a Program Name and store it.

• If a Program Name exists in Verifone C-Site Management that matches the Program Name in the 
site’s local Mobile Payment Configuration, Verifone C-Site Management program will automatically 
update the site’s configuration.

Configuration Updates

• After the initial upload of the current configuration, any updates made in Verifone C-Site 
Management can be sent to the site by either the major oil provider and/or the merchant 
administrator (if applicable.) 

• After the site is onboarded to the cloud, Mobile Payment Configuration management will still be 
available within Verifone Configuration Client.

• If there are local changes within Verifone Configuration Client made to the Mobile Payment 
Configuration at the site, these changes will NOT be transmitted to Verifone C-Site Management. 

• If updates are sent to the site from Verifone C-Site Management, the last update sent will override 
previously transmitted or locally stored data.
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Mobile Payment Programs
The Mobile Payment Program page allows multiple mobile payment configurations to be built and assigned 
to each site. Each program has a specific individual Program Name. Programs can be created in Verifone 
C-Site Management, or they can be added when the site is onboarded to Verifone C-Site Management. 

Create Program

1. To create a new Mobile program, navigate to C-Site Management > Configuration > Site Management 
> Select the Sites drop down and switch the view to Enterprise. 

2. After navigating to the Enterprise view, select + Create New in the top right corner. 

3. From the Create New Data Set pop up, select the Configuration Category of Payment Operations. 
Select the Configuration Type of Mobile.
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4. Click Continue to open the creation form.

5. Complete the following parameters shown specific to the Mobile Payment Host being configured. See 
table below for details on each field.

6. Select Apply Changes to save the parameters entered.
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Field Description

Adapter Select the communication standard being used:

· VFI Mobile V1 - Connexxus V1 Standard

· VFI Mobile V2 - Connexxus V2 Standard

Program Name The program name is specific to the Mobile Payment Configuration. This parameter must be unique 
as it is the identifier for the Mobile Payment Configuration.

Authentication Type · Scan Token - QR Code Generated on the Mobile Payment Application is scanned using the 
POS Scanner

· Enter Token - Customer or cashier enters a token on the PIN pad.

· Display Token - A token for the customer to enter on PIN pad.

· Generate Token - Both Display Token and Generate Token display a token on the PIN pad to 
be scanned or entered for authenticating the transaction. If a site has different Mobile 
Payment programs configured with Generate Token authentication type for all, the customer 
is not prompted to select a mobile payment program during the transaction. After selecting 
the mobile MOP, the PIN pad displays a QR code instead of a mobile payment programs 
election. 

Send Loyalty Details Enabling this flag sends SLA/EPS loyalty program details to the Mobile Host Provider.

Address (IPv4 Format/
Domain Name)

Host IP or URL (IPv4 Format or HTTP domain name)

Port Communication Port Number

Heartbeat Frequency The time after which the Verifone Commander pings the mobile program host to check connection. If 
the host is offline, a mobile host offline alarm message will appear on the POS. 

SSL Enabled Enables Secure Socket Layer (SSL) for client/host communications.

Outdoor 
PreAuthorization 
Timeout (In Secs)

The DCR pre-authorization time out in seconds. 

Site Initiated Loyalty Select the site-initiated loyalty settings for outdoor transactions:

· Never Allow Site Entered Loyalty - Only allows mobile loyalty.

· Allow Site Entry i.e., Swiped Loyalty Card- Both swiped and mobile loyalties allowed.

· Allow Site Entered Loyalty if no Mobile Loyalty - Allows swiped loyalty is there is no mobile 
loyalty.
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Edit an Existing Program

1. To edit an existing Mobile program, navigate to C-Site Management > Site Management > Select the 
Sites drop down and switch the view to Enterprise. 

2. Check the Viewing selection to the right of the filter button. If it is not set to Viewing: Mobile, then use 
the Filter function to switch to Mobile (Configuration Category: Payment Operations | Configuration 
Type: Mobile). 

3. Select the three dots to the right of the Program Name view/edit. 

4. Click View/Edit.

5. The General tab will display by default. The Sites tab will show which locations have this program 
applied. 

6. After changes have been made to the configuration, confirm that those changes are correct and select 
Apply changes in the top right corner of the screen. 
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Delete an Existing Program

1. To delete an existing Mobile program, navigate to C-Site Management > Site Management > Select 
the Sites drop down and switch the view to Enterprise.

2. Check the Viewing selection to the right of the filter button. If it is not set to Viewing: Mobile, then use 
the Filter function to switch to Mobile (Configuration Category: Payment Operations | Configuration 
Type: Mobile). 

3. Select the three dots to the right of the Program Name you wish to remove. 

4. Click View/Edit.

5. Use the Sites tab to see which sites have the Mobile program applied to it. 

6. Use the General tab to remove the program, by selecting Remove Program in the bottom right corner of 
the screen.

 WARNING Deleting the existing program within the Enterprise configuration will delete the 
Mobile configuration from any associated sites. 
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MID Bulk Upload

MID Bulk Upload feature allows for site specific MIDs to be added in bulk for one specific program. This 
feature is useful for onboarding multiple sites within a new Mobile Payment host program. 

The MID Bulk upload feature requires the site’s service ID and the site specific MID to be known. 

1. To use MID Bulk Upload, navigate to C-Site Management > Site Management > Select the Sites drop 
down and switch the view to Enterprise.

2. Check the Viewing selection to the right of the filter button. If it is not set to Viewing: Mobile, then use 
the Filter function to switch to Mobile (Configuration Category: Payment Operations | Configuration 
Type: Mobile). 

3. Select the three dots to the right of the Program Name you wish to remove. 

4. Click View/Edit.

5. Select MID Bulk Upload in the top right corner of the Site selection screen.

6. Select the 
Downloading Excel 
Template File link on 
the Template 
Download screen. 
After the template is 
downloaded, fill in 
the Service ID fields 
along with the 
associated site 
MIDs. 

7. Save the document 
to your computer 
and click Continue 
on the Template 
Download screen. 
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8. Either drag and drop the saved Service ID / MID list file into the dotted lines or browser for the files. After 
the file is found, select the Upload File button.

9. The screen will return to the MID Bulk Upload form. A “Done” message will appear in the left side of the 
screen. To upload more MIDs to the selected program, select Upload Again. 

10. To view the result of the upload, select the MID Bulk Report on the left column. The MID Bulk Report will 
display the last five MID Bulk Upload results. It is recommended to review the results after the upload to 
confirm if the MID was successfully uploaded to the entered Service ID.
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13 PRIMARY PAYMENT (ENTERPRISE)

Primary Payment Configuration in Verifone C-Site Management allows for Primary Payment settings to be 
configured and managed in the cloud, and then transmitted to a single or multiple sites. Support Primary 
Payment remote management within the Verifone C-Site Management application requires software 
Release 55.02 or higher.

Primary Payment Configuration in Verifone C-Site Management does NOT set up the Method of Payment 
(MOP), touchscreen, and DCRs. For details on how to configure payments locally within Verifone 
Configuration Client, see the Commander User Reference manual.

Primary Payment Programs
The Primary Payment Program page allows multiple primary payment configurations to be built and 
assigned to each site. Each program has a specific individual Program Name. Programs can be created in 
Verifone C-Site Management, or they can be added when the site is onboarded to Verifone C-Site 
Management. 

Create Program

1. To create a new Primary Payment program, navigate to C-Site Management > Configuration > Site 
Management > Select the Sites drop-down menu and switch the view to Enterprise. 

2. After navigating to the Enterprise view, select + Create New in the top right corner. 
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3. From the Create New Data Set pop up, select the Configuration Category of Payment Operations. 
Select the Configuration Type of Primary Payment.

4. Click Continue to open the creation form.

5. Complete the following parameters shown specific to the Primary Payment > Cashback and Fees 
being configured. See table below for details on each field.
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6. Select Next to continue to Card Price Tiers.

Field Description

Cashback Enabled Enables cashback on cards. Cashback fee is an added amount to the customer’s transaction to cover 
the processing cashback on a debit card.

Force PIN Entry Enforces the customer to enter a PIN.

EMV Cashback Prompt 
– Wait for Cashier?

The transaction waits for the cashier to approve cashback on the POS that was entered on the PIN 
pad.

Cashback Fee Sets the Cashback Fee. 

EBT Cashback Enabled Enables Electronic Benefits Transfer (EBT) Cashback.

Enable Convenience 
Fee

Enables the convenience fee. Convenience fee is an added amount to the customer’s transaction to 
cover the higher costs of processing a credit or debit card rather than using cash or check.  

Fee Amount Sets the amount to be used for the Convenience Fee. 
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7. Complete the following parameters shown specific to the Primary Payment > Card Price Tiers being 
configured. See table below for details on each field.

8. Select Next to continue to Site(s) Assignment.

Field Description

Version It is the name given to the Primary Payment Configuration entered in the Review form after the Site(s) 
Assignment. The default configuration version is zero. 

Select Card Select a card to assign a Price Tier. 

Price Tier Assigns “Cash” or “Credit” to the card selected.

Discard Changes Removes recent changes.
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9. Complete the following Site(s) Assignments shown specific to the Primary Payment being configured.

10. Select Next to continue to Review. Review the following parameters and then click Back if changes are 
needed. 
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11. Enter the name of the Primary Payment Configuration that will be shared across sites. 

12. Click Submit.
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Card Price Tiers

1. To edit an existing Primary Payment program, navigate to C-Site Management > Site Management > 
Select the Sites drop-down menu and switch the view to Enterprise. 

2. Check the Viewing selection to the right of the filter button. If it is not set to Viewing: Card Price Tiers, 
then use the Filter function to switch to Primary Payment (Configuration Category: Payment Operations 
| Configuration Type: Primary Payment). 

3. Select the three dots to the right of the Program Name view/edit. 

4. Click View/Edit.

5. The General tab will display by default. The Sites tab will show which locations have this program 
applied. 

6. After changes have been made to the configuration, confirm that those changes are correct and select 
Save Changes in the lower right corner of the screen. 
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Cashback & Fees

1. To edit an existing Primary Payment program, navigate to C-Site Management > Site Management > 
Select the Sites drop-down menu and switch the view to Enterprise. 

2. Check the Viewing selection to the right of the filter button. If it is not set to Viewing: Cashback & Fees, 
then use the Filter function to switch to Primary Payment (Configuration Category: Payment Operations 
| Configuration Type: Primary Payment). 

3. Select the three dots to the right of the Program Name view/edit. 

4. Click View/Edit.

5. The General tab will display by default. The Sites tab will show which locations have this program 
applied. 

6. After changes have been made to the configuration, confirm that those changes are correct and select 
Save Changes in the lower right corner of the screen. 
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14 SITE CONFIGURATION

Site Configuration in Verifone C-Site Management allows for site level price book configurations to be 
configured and managed in the cloud, and then transmitted to a single or multiple sites. Support for Site 
Configurations remote management within the Verifone C-Site Management application requires software 
Release 54.01 or higher.

Site Configurations consists of the information previously located under Store Operations in Configuration 
Client.

Configuration Syncing

Initial Onboarding

• When the Verifone Commander is initially onboarded into the cloud, if it is on Release 54.01 or higher, 
it will transmit its current Site configuration to the Verifone C-Site Management application. 

• The current configuration is only transmitted to the Verifone C-Site Management application during 
the initial onboarding. 

Configuration Updates

• After the initial upload of the current configuration, any updates made in Verifone C-Site 
Management can be sent to the site by the merchant administrator. 

• If updates are sent to the site from Verifone C-Site Management, the last update sent will override 
previously transmitted or locally stored data.

• Any changes performed on the local site Verifone Commander will sync to the Verifone C-Site 
Management. 

 

NOTE A message will be displayed on Site Configuration forms when the Verifone Commander 
software release version doesn't support configuring the form.         
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Site Search
1. Site Configurations are uploaded and managed by each individual site. To search for the specific site, 

navigate to C-Site Management > Site Management.

2. Sites can be searched in three ways:

• Searching by site name.

• Using the Hierarchy drop-down menu to filter specific groups of sites.

• Paging through the site listings.

3. After locating the site to view, select it from the list to open the site configurations.
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Replicate Configuration
The Replicate Configuration feature allows a site’s datasets to be copied from one location to multiple other 
site locations. Support for this functionality relies upon the datasets being present and available in both the 
Source Site and the Destination Site(s). 

1. To replicate a site’s configuration, navigate to C-Site Management > Site Management. Select 
Replicate Configuration from the top right corner.

2. Select a source site from the drop-down menu. The source site must be onboarded to be selected. 
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3. Select the configuration(s) to be copied from the available list. Be aware that if the destination site(s) do 
not have the dataset available, they will not appear in the Select Destination Site(s) list. 
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4. Either search for the site(s) by name using the ‘Search by Name’ field, or use the hierarchy selection 
drop-down menu to select the site(s) to copy the datasets to. 

 

5. Select Save to complete the transfer to the selected site(s). Changes made to the locations dataset can 
be checked within the Site’s configuration page. Selecting Discard will cancel all the options selected 
and reset the form. 
                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         95



                                                                                                                                Verifone C-Site Management User Guide
 

Store Operations
The following Store Operation configurations are currently available under C-Site Management > 
Site Management:

• Methods of Payment (MOPs)

• Currencies

• Fees

• Tax Rates

• Categories

• Departments

• PLUs

• Blue Laws

• ID Checks

• Sales

• Images

• Menus

• Touch Screen

• Tipping

• House Accounts

• Charity Donations
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Method of Payment (MOPs)

Method of Payment configuration allows payments that are accepted at the store to be configured and 
modified. Preconfigured MOPs are loaded into the Verifone Commander at the time of installation. MOPs 
can only be selected if they are configured on the point-of-sale touch screen or self-checkout. It is best 
practice to leave any unused MOP configurations available in case they are needed in the future. 

Field Description

ID The record number for the Method of Payment.

Name The name of the method of payment is entered here. The name will appear on receipts and reports. 
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MOP Code The MOP Code defines how the MOP should function. Review the list to determine which MOP should 
be used. Selection may vary depending upon the network configuration:

0 - Cash: Used for cash transactions that will be accepted at the POS. 

1 - Credit: Used for credit cards sent through the card network. Some reports may show this MOP as 
‘Charges’ or by card name.

2 - Debit: Used for debit cards that require a PIN entry prompt on the PIN pad. Tender amount 
required should not be selected for this option.

3 - Manual Credit: Used for credit cards not sent through a credit card network. 

4 - Manual Debit: Used for debit cards not sent through a credit or debit card network. 

5 - Lotto: Used for winning lotto tickets tendered as MOPs.

6 - Check: Used for written checks. If customers are not permitted to write checks for more than the 
amount of purchase, do not enable ‘Change Allowed’ setting.

7 - Tax Coupon: Use for product coupons as MOPs. The ‘Change Allowed’ parameter should not be 
enabled. 

8 - $1 Cash: Automatically enters the tendered amount as $1.00 cash. ‘Tender Amount Required’ 
should not be selected for this option. 

9 - $5 Cash: Automatically enters the tendered amount as $5.00 cash. ‘Tender Amount Required’ 
should not be selected for this option. 

10 - $10 Cash: Automatically enters the tendered amount as $10.00 cash. ‘Tender Amount Required’ 
should not be selected for this option. 

11 - $20 Cash: Automatically enters the tendered amount as $20.00 cash. ‘Tender Amount Required’ 
should not be selected for this option. 

12 - $50 Cash: Automatically enters the tendered amount as $50.00 cash. ‘Tender Amount Required’ 
should not be selected for this option. 

13 - Food Stamp: Used for paper food stamps only. Amounts entered must be as whole dollars for 
this MOP.

14 - Drive Off: Used to setup an MOP for clearing fuel sales for customers that drive off without 
paying for dispensed fuel. 

15 - Special Discount: A MOP used to provide a percentage based discount applied to PLUs and 
Department sales enabled for special discounts. See the Special Discount Feature Reference for 
more details.

16 - Manual FS: Electronic, non-paper food stamps. 

17 - Lottery: Used for scratch-off lottery tickets tendered as MOPs.

18 - In-House: Store credit method of payment used to provide local vendors/customers a store 
manage invoicing payment type. See the In-House Account Feature Reference for more details.

19 - Pump Test: Used for testing dispensers. Typically, used during installation of new dispensers and 
POS equipment. 

20 - EBT Food Stamp: Electronic, non-paper food stamps.

21 - EBT Cash Benefit: Electronic, non-paper cash benefit.

22 - Manual EBT CB: Manual non-paper cash benefit.
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MOP Code (Cont’d) 23 - ECheck: Standalone electronic check processing. The balance of the ticket amount is sent to the 
host for approval.

24 - Stored Value Card: Used for prepaid stored value cards.

25 - Manual Entry: Selected for manual entry of credit card numbers. Check with the card processing 
network to see if this functionality is permitted.

26 - Force Post: This MOP is used when entering transactions that were processed when the host 
was offline.

27 - Post Entry 

28 - Mobile: Used for Mobile Payment. See the Mobile Payment Feature Reference guide for more 
information.

29 - Unattended Refund: Used refunding unattended fuel sales.

30 - Non-Tax Coupon: Used for Product coupons as MOPs. Tax due may be reduced because of 
applying this coupon.

31 - Fuel Voucher: Used for fuel vouches (paper) only.

32 - Tax Exempt Voucher: When applied, the MOP will reduce the amount due based on which taxes 
are configured to be exempt. Multiple types of tax exemptions can be configured, and the appropriate 
prompts will be presented to the cashier based on the configurations.

33 - Fleet Check: Fleet Checks can be exchanged for cash or be used as MOP in a transaction. See 
the Fleet Cards Feature Reference for more information.

Min. Amount The minimum amount accepted by the MOP. (0.00-9999.99)

Max Amount The maximum amount accepted for this MOP (0.00 - 9999.99)

Limit The drawer limit amount is entered in this field. When the limit is reached the POS will prompt the 
cashier to perform a Safe Drop. Ensure Allow Safe Drop is selected when a drawer limit is set. 

# of Additional 
Receipts

Prints additional receipts for the MOP. Force Ticket Print must be selected to enable this parameter. 
Some transaction types and MOPs will print additional receipts regardless of this setting. 

Tender Code Used to assign the NACs tender code to Verifone MOPs. Helps to create the NAXML POS Journal 
from the transaction log without manually looking up or mapping the tender. The recommended value 
is the default values for each MOP. In order to select a new value from the list or enter a new value 
other than from the list, delete the default value first.

Tender Sub Code Used to assign the NACs tender code to Verifone MOPs. Helps to create the NAXML POS Journal 
from the transaction log without manually looking up or mapping the tender. The recommended value 
is the default values for each MOP. In order to select a new value from the list or enter a new value 
other than from the list, delete the default value first.

Force Safe Drop Forces the cashier to perform a safe drop before any further sales can be performed on the register. 
This selection will automatically enable Allow Safe Drop. A limit (drawer limit) must also be configured 
for this functionality to work properly. 

Open Drawer on Sale Opens the cash drawer when the method of payment is selected. 

Tender Amount 
Required

Requires the cashier to enter the amount tendered (cash/payment given) before selecting the method 
of payment. 

Cashier Report Prompt Prompts the cashier to enter the actual (counted) drawer total for this MOP when printing the cashier 
report under CSR Functions > Reports > Print Cashier Report. 
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Allow Zero Entry Allows the amount of zero to be entered when entering the actual (counted) drawer totals for this mop 
when printing the cashier report. 

Allow Without Sale Allows the method of payment to be used when there are no sales / items rang into the register. For 
example, if the MOP was cashing winning lottery tickets, then the customer would not need to 
purchase anything in the store.

Allow Refund Allows this method of payment to be used for Refunds.

Allow Change Allows the cashier to provide change to the customer when the tendered amount is more than the 
transaction total. Used for cash transactions and when the store allows cash back for checks. 

Allow Safe Drop Allows this method of payment to be used with the safe drop function. If a drawer limit is set, then this 
function must be enabled.

Allow Money Order 
Purchase

Allows this method of payment to be used for the purchase of money orders. See the Money Order 
Feature Reference for more details.

Force Ticket Print Forces the receipt to print at the end of a transaction.

Force Quick Cash Key Allows a set amount to a Speed Cash key using the “00-Cash” MOP code.

Allow Lottery Purchase Allows this method of payment to be used for the purchase of lottery.
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Currencies

Currencies are used to define an alternative currency that can be accepted at the store along with the 
exchange rate. Up to two currencies can be configured, with the default currency set to US Dollars.

 

Field Description

Name The name of the currency. All method of payments uses the default US Dollar currency unless the 
Other Currency function (must be added to the touchscreen) is used. 

Symbol The symbol that will appear on the receipt representing the currency.

Currency Code The official three letter ISO 4217 currency code. For example, USD stands for US Dollar and CAD 
stands for Canadian Dollar.

Exchange Rate For the default currency, the exchange rate will always be 1.00000, however when setting a 
secondary currency, the exchange rate will be the exchange rate based off the software release / 
default currency. For example, the exchange rate for the Canadian Dollar would be entered as $1.32 
(According to the July 14th,2023 exchange rate.)

Singular Print Name Allows the singular printed name for the currency to be modified.

Plural Print Name Allows the plural printed name for the currency to be modified.
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Fees

Fees are used to charge an additional amount to a department or PLU. Up to 99 different fees can be 
added. 

 

Field Description

Name Enter a descriptive name for the fee. The name prints on the receipt.

Department The department assigned here is where the fee totals will appear in reports. 

Fee is Refundable Allows the fee to be refunded with the original sale. 

Fee Type Percentage - Enter a flat percentage that will be charged for the department or PLU sale. 

Amount Range/Amount - Calculates the fee amount based on the department or PLU sale. This fee type uses 
a dollar range to determine the fee amount. 

Range The ending dollar amount for which the fee will be charged. If left at 0.00, it will default to the 
maximum amount allowed by the register. The starting dollar range for the first fee is always 0.00. 
The first range entry (top right) is from $0.00 to $xx.xx. The second range value will start at the next 
cent of the previous range.
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Tax Rates

Tax rates configurations allows for up to eight different tax rates to be configured at one location. Tax rates 
can be added to departments or PLUs after they have been created to ensure the correct tax amount is 
collected on different types of sales. 

Field Description

Name Enter a descriptive name for the fee. The name prints on the receipt.

Indicator Assigns an indicator to the item the tax was added to. The indicator will print out on the receipt to 
indicate one or more taxes were applied to specific departments or plus. 

Rate Enter in the percentage of the tax rate. For example, if the state tax rate was 7% then the rate would 
be 7.

Percent Start The minimum dollar amount that can be taxed. For example, if taxes did not apply to transactions less 
than $0.10 then the percent start would be $0.10.

Price Includes Tax Select this option if the price includes taxes. 

Use Canadian GST Used for Canadian Goods and Services tax. 

Use Breakpoint Table Select this option if the taxes configured require a breakpoint table. A breakpoint table specifies the 
taxable amount for the department or PLU it is assigned based on the cost of the individual line item.

Prompt for Exemption See the Verifone Commander User Reference for more details on Breakpoint Tax configurations.
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Categories

Categories are used to group departments for reporting purposes. Categories consist of a number from 
1-9999 and a Name. Use the Add button to add a new category or Delete to remove an existing category.
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Departments

A department is a group of similar PLUs/items. For example, the Frozen Foods department may consist of 
ice cream, Popsicles, and frozen pizzas. Up to 9999 departments can exist within the configuration. Do not 
use Departments 9990-9999 as they are reserved for specific purposes.

Field Description

Number Enter in an unused number from 1-9990

Name Enter the name of the department. If items are rung in using the department the name will appear on 
the receipt.

Minimum Amount The minimum allowable dollar amount for a line-item sale using this department or an item within this 
department. 
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Maximum Amount The maximum allowable dollar amount for a line-item sale using this department or an item within this 
department. 

Product Code Assign a product code that categorizes the products sold accurately. Product codes are used by the 
card processing network to properly categorize items and may prohibit the sale of certain items for 
specific cards. If you are unsure what product code to use for a specific item, contact your card 
processing network for direction. Departments MUST have a product code assigned.

Category Departments can be assigned to categories for reporting purposes. Categories are not required.

Fuel Tax Exemption Only used by fuel departments that allow a fuel tax exemption to be applied to the sale. 

Transaction Quantity 
Limit

Limits the number of line items per transaction. The default value of 0.00 indicates there are no 
restrictions.

Fees Assigns a predefined fee to the department that will be assessed based on the Fee configuration. 
Multiple fees can be assigned to a single department.

ID Checks Prompts for an ID check when a transaction using the specified department is used. Multiple ID 
checks can be assigned to a single department.

Taxes Charges different tax rates that are selected for the specified department. Multiple taxes can be 
assigned to a department. 

Blue Laws If the sale of an item is restricted to specific times and/or days, then a blue law can be assigned. 
Multiple blue laws can be assigned to the department.

Allow Food Stamps Select this option if the department qualifies for food stamps.

Fractional Quantity Select this option if items are sold by weight. For example, if the quantity is 1 3/4 lbs of turkey, then 
entering in the value of 175 and selecting a department with fractional quantity enabled will enter in 
1.75 instead of 175.

Fuel Department If the Department is used for Fuel, then this option should be selected. 

Prompt Serial Number Enable this to prompt for the serial number that is entered by the cashier and printed on the receipt. 
For example, if the store is selling electronic devices they may want to prompt for serial numbers or 
warranty or return purposes.

Special Discount Select this parameter if special discounts can be applied to this department. 

Negative Department Select this option if the items rang into this department, are a negative value. For example, a coupon 
department would subtract from the transaction total rather than add to it. 

Money Order 
Department

If the department is used for selling Money Orders, then this option should be selected. See the 
Money Order Feature Reference for more details. 

Prohibit Manual 
Discount

Prohibits discounts configured to be applied using the discount function. This parameter does not 
affect PLU promotions, NAXML Promos, or Loyalty line-item discounts. 
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PLUs

PLU or Price Loop Ups are the individual items added to the price book. PLUs may be scannable 
(representing a barcode) or may be assigned to buttons or menus on the touch screen. PLUs can be 
created within Site Configuration > Location Name > Store Operations > PLUs. The add and delete button 
can be used to create new PLUs or delete the selected PLU from the store’s price book. 

Field Description

Search Description Use this area to search for the description of an item. The filter icon next to the search description box 
allows the search to be filtered by UPC, Description, Department, Product Code, and Price.

PLU The PLU number is the number used to identify the product. The field supports up to 14-digits. If the 
item has a barcode, then the PLU will be based on the barcode information. If the item does not have 
a barcode, the PLU can be any unused number in the pricebook. PLUs can be assigned to a 
touchscreen button, a menu, a key, or entered in manual using the on screen keypad when in sales 
mode.

Check Digit This field will automatically be entered upon saving a new PLU. It cannot be modified
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Modifier The modifier is used to create a PLU using the same PLU number but allow different pricing points or 
PLU configurations to be set. For example, if you sold a 6 pack of soda the barcode would be the 
same if you sold them in individual cans. If a modifier is added to the single can or 6 pack PLU, when 
scanned the POS will present two options for the cashier to select the correct option the customer is 
purchasing. A maximum of 3-digits is supported. If modifiers are not used with the PLU, then this is left 
at 000.

Description The name that appears on the POS, line-item display, and customer receipt to identify the item. 

Price The price of the item.

Sell Unit The smallest unit of a product that is sold to a customer. This is typically left at 1.

Calories Assigns calories to an item to be displayed on the Verifone C18 Self Checkout. If left blank, no calories 
will be displayed.

Department The department is used to group PLUs and is a required field for PLUs. Select the drop-down menu to 
assign the appropriate department to the PLU. If one does not exist, see the previous section to 
create a new department for the item. 

Product Code Assign a product code that categorizes the products sold accurately. Product codes are used by the 
card processing network to properly categorize items and may prohibit the sale of certain items for 
specific cards. If you are unsure what product code to use for a specific item, contact your card 
processing network for direction. 

Fees Assigns a predefined fee to the department that will be assessed based on the Fee configuration. 
Multiple fees can be assigned to a single PLU.

Taxes Charges different tax rates that are selected for the specified department. Multiple taxes can be 
assigned to a PLU.

ID Check Prompts for an ID check when a transaction using the specified department is used. Multiple ID 
checks can be assigned to a single PLU.

Blue Laws If the sale of an item is restricted to specific times and/or days, then a blue law can be assigned. 
Multiple blue laws can be assigned to a PLU.

Group ID The group ID to which the PLU belongs. When one of the items in the group is scanned, the system 
will allow the cashier to select from a menu of the grouped items. The selected item is added to the 
ticket, which may not be the original item scanned. This feature only works if enabled within System 
Properties at the store level. 

Sequence The sequence number is used with the Group ID to determine the order of the PLU in the group.

Trans Qty Limit Limits the quantity of the item that can be sold in a single transaction.

Open When enabled, allows the price to be entered when the item is sold. Creates a PLU that functions like 
a department sale but can be used to be more specific.

Returnable Determines whether the item can be returned to the store by using the refund function on within sales 
mode on the POS. If the item is not returnable, then deselect this option. It is enabled by default.

Special Discount Select this parameter if special discounts can be applied to this PLU.
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Fractional Quantity Select this option if items are sold by weight. For example, if the quantity is 1 3/4 lbs of turkey, then 
entering in the value of 175 and selecting the PLU with fractional quantity enabled will enter in 1.75 
instead of 175.

Prohibit Manual 
Discount

Prohibits discounts configured to be applied using the discount function. This parameter does not 
affect PLU promotions, NAXML Promos, or Loyalty line-item discounts.

Not Sold Select this option if the PLU cannot be sold within sales mode, but still needs to remain in the price 
book for reporting purposes.

Food Stamp Select this option if the department qualifies for food stamps.

Promo The promo options allows the PLU to be used within a PLU Promotion. This option is enabled by 
default. If the item isn’t set up within PLU Promotions, then it will not apply any promotion. 

Prompt Serial Number Enable this to prompt for the serial number that is entered by the cashier and printed on the receipt. 
For example, if the store is selling electronic devices they may want to prompt for serial numbers or 
warranty or return purposes.

Taxable Rebate The rebate amount and taxes that are applied to the rebate amount can be assigned here. Taxable 
Rebate must be enabled within Sales Configuration > Enable Receipt Tax Detail.
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Blue Laws

Blue Laws prohibit the sale of certain items during specific days and times. Blue Laws are dependent upon 
local government laws/regulations. Up to two blue laws can be configured.

Adding a Blue Law

1. Select the Blue law from the drop-down list in the top left corner. 

2. Select the days of the week the blue law applies. 

3. Enter in the start and end times for the blue law. Times are entered based on military time. There are 
two start and end times that can be used in the event the blue law starts at midnight and ends in the 
morning, but then starts again in the afternoon. 

Values can be copied to different days of the week by selecting the three dots to the right of the End 2 
time. The change applies to the selected day of the week immediately upon selection.
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4. Blue Laws can be assigned to Departments and PLUs after they are created.
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ID Checks

ID Checks allow the point of sale to prompt the cashier to collect the customer’s ID information to confirm 
they are old enough to purchase the product. There can be up to six different ID Checks configured. See the 
Age Restriction Feature Reference Manual for more information on ID Check configuration.

Field Description

Name The name of the ID check will be entered here. 

Age The minimum age of the customer who can purchase the item. The date calculation is based off the 
local Verifone Commander’s date and time settings.

Bypass ID Check If this parameter is enabled, it allows the cashier to skip the ID Check and confirm the customer is 
allowed to purchase the item. If the cashier does not select confirm, then the item is not added to the 
transaction.

Security Level This setting is used with the Bypass ID Check field. The security level field sets a security level for the 
Bypass ID function. For example, if the security level was set to 7 then POS users with security level of 
7 would be able to use the Bypass ID check function.
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Confirmation Prompt This setting is used with the Bypass ID Check field. It will prompt the cashier to accept the 
confirmation prompt that the customer is permitted to buy the item. 

Force Scan / Swipe 
Only

When Force Scan/Swipe Only is enabled, the cashier is not allowed to enter the details manually. 

A bar code scanner or magnetic strip reader (MSR) captures birth date information from the ID card’s 
bar code or magnetic stripe. The collected information will perform an automated mathematical 
check to ensure the consumer meets the minimum age requirement to approve the transaction.

If the consumer is below the minimum age requirement, the transaction will not complete.

Perform ID Legitimacy 
Check

This setting is used with Force Scan/Swipe Only. A bar code scanner or MSR captures at least two 
pieces of personal information from the ID card’s bar code/magnetic stripe and temporarily display 
them to the clerk on the POS screen.

• Piece of personal information #1: ID Card Full Name

• Piece of personal information #2: License Number

The cashier compares the information displayed on the POS screen with the information on the 
physical ID. If there is no mismatch the cashier can approve the transaction, or they can decline the 
transaction if there is a mismatch between the information presented.

Manual Security 
Override

This setting is used with Force Scan/Swipe Only. When selected, a POS user with a high enough 
security level can manually enter ID details even when ‘Force Scan/Swipe Only’ is selected. 

The Security Level drop-down menu below this option is the security level set for Manual Security 
Override.

Online Age Verification Enable for TruAge Digital ID verification. Additional settings are needed for this functionality to work. 
See the Age Restriction Feature Reference for more details.

Exceptions Military and date-based exceptions can be configured for each ID Check. 

Military Exception - After manual entry of the date of birth (DOB) from the ID, if the DOB fails standard 
minimum age limit check, but passes military minimum age limit test, a prompt will appear for the 
cashier to confirm if it is a military ID.

Date Based or Grandfather Exception - Grandfather age check is based on a past minimum age 
requirement. If the DOB check meets this secondary date-based exception, the transaction can be 
completed.
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Sales

Sales Configuration

The sales configuration form is used to configure sales functions such as Print Receipt, Force DOB on ID 
Check, Error correction Security level, and other sales related functions.

Field Description

Allow Amount Entry for 
Refund

Allows amount entry for refund so that the cashier can give the amount entered as refund to the 
customer as a roundoff figure after taking the difference from the customer.

Canadian GST Select if the site collects Canadian GST tax. Special prompts for Canadian GST appear in the Tax 
Rate File.

Cardload Recharge 
Dept

Select to assign the department number for cardload recharge.

Cash Drawers 
Connected

Allows the number of cash drawers connected to the POS to be increased from one to a maximum of 
two cash drawers. Connecting two cash drawers allows two cashiers to utilize one point of sale, while 
keeping their drawer totals separate. 

Cash Under Run Auto 
Refund

If disabled, cashier must complete the underrun transaction by selecting a MOP. If enabled, when 
cashier claims the fuel sale, amount is automatically refunded.
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Check Drawer Amount 
on Safe Drop

Select to compare the amount of the MOP entered to the calculated amount currently in the cash 
drawer.

Count Underrun 
Customers

When a cashier completes a prepay underrun transaction, the underrun customer count is 
incremented in the Summary Report, Shift Report and Daily Report with the attribute “Underrun 
Customer”.

Disable Error Correct 
Key

“Error Correct” button is not displayed on the POS touchscreen when this parameter is enabled.

Discount Denomination See the Discount Denominations in the Verifone Commander User Reference for configuring 
discounts.

Select so that when the cashier selects the discount key (hard key, soft key, or touch-to-modify 
menu), any configured discounts are displayed as part of the discount overlay.

Discount Type – Pct or 
Amt

Select the type of discount to apply when the Discount function/button is used.

Percent — The discount is calculated as a percentage of the price and then subtracted from the price 
of the item.

Amount – The Discount is directly subtracted as a dollar amount from the price of the item.

Display PLU Not Found 
Department List

Select to set a department number to assign to PLUs that are not in the PLU department list.

Drawer Alarm Timer Enter the number of seconds a cash drawer is allowed to remain open before an alarm is triggered 
(0-99). “Drawer Open During Sale” must not be selected for the drawer alarm time to work.

Drawer Open During 
Sales

Allows the cash drawer to remain open during transactions. If it is not selected, the cash drawer must 
be closed before the next transaction can be started.

Employee Number 
Login

Allows a cashier to login using their Employee Number instead of their POS ID number. The employee 
number is assigned within Security > POS Security > Employees. When enabled all employees must 
login with their employee number. 

Enable Auto Settle 
Overrun

Select to determine whether to apply a charge on a prepaid sale in case of an overrun. When enabled, 
the overrun amount should automatically be settled to “Drive Off” MOP to complete the transaction.

Enable Managed 
Update

Enable to provide an interim approval step during the PLU file update process and to allow updates to 
take effect within the POS system immediately upon approval. No restart required after approval.

Enable Receipt Tax 
Detail

Enable to print the tax details on the receipt. Even if this feature is disabled, if there is a taxable rebate 
in the transaction, the tax details are printed on the receipt.

Error Message Prompt 
Timer

Enter the length of time (in seconds) that error messages display (2 - 30).

Fixed Discount Rate If “Is Fixed Discount” is selected, enter the percent or amount (set in “Discount Type”) that is 
automatically applied when the Discount button is pressed.

Food Service Default 
PLU

Not Used.

Force DOB on ID Check Select to force ID checks by displaying messages, beeping, and restricting sales until a birth date is 
entered, scanned, or swiped.
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Force No Sale Print Prints a receipt for any No Sales that are completed. 

Force Refund Print Prints a receipt for any Refunds completed.

Force Void Line Print Prints a receipt for any transactions that contain a Void Line.

Force Void Transaction 
Print

Prints a receipt for any transactions that were Voided.

Fuel Discount Enter the dollar amount per gallon discount that is applied when a fuel discount key is used (0.00 – 
99.99).

Fuel Discount Title To rename Fuel Discount with a descriptive name, enter up to 30 characters.

Idle Prompt Displays 
Due Sale

Not Used.

Is Fixed Discount Select to automatically enter discounts (set in “Discount Type” as a percent or amount) for the 
amount entered in “Fixed Discount Rate” when the Discount button is pressed. If it is not selected all 
discounts must be entered as individual amounts. 

Is cashier # required for 
each sale

Select to require the cashier/employee number and password before starting each sale.

Is subtotal required Requires the cashier to select the Total button before the Method of Payment (MOP) can be selected.

Is total in double Prints the transaction in Double-Wide characters on the Receipt.

Maximum Amount Enter the maximum amount that any one department item may cost if ‘0’ is entered for Department > 
Maximum Amt (0.00 – 9999.99)

Maximum Discount Enter the maximum discount (either percent or dollar as set in “Discount Type”) that can be applied to 
an item when using the Discount button (0.00 – 99.99).

Maximum Quantity Enter the maximum quantity of any one item that may be sold in one transaction (0.00 – 9999).

Maximum Till 
Transaction Amount

Enter the maximum transaction amount. 

Minimum Amount Enter the minimum amount that any one department item may cost if ‘0’ is entered for Department > 
Min Amt (0.00 – 9999.99). 

Minimum Discount Enter the minimum discount (either percent or dollar as set in “Discount Type”) that can be applied to 
an item when using the Discount button (0.00 – 99.99).

Money Order Low Enter the number of checks remaining before an alarm message indicates that the money order 
machine needs to have more checks loaded (0 - 99). See the Money Order Feature Reference for 
more information on this feature.

One Cashier Per 
Drawer

Select to limit login to one cashier per cash drawer until totals are closed. This can be overridden by 
personnel with higher security levels than the cashier. If not selected, more than one cashier is 
allowed per cash drawer.

Open Drawer Cashier 
Close

Select to close open drawer before another cashier can use the cash drawer. 
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PLU Not Found 
Department

Enter a department number to assign to PLUs that are not on the PLU File and are entered as a sale 
(0 – 9999). Entering a value of 0000 disables the department not found function. The department 
record must be available within the Department configuration.

Prepaid Card Activate 
Department

Enter the department number for prepaid card activation sales transactions.

Prepaid Card Recharge 
Department

Enter the department number for prepaid card recharge sales transactions.

Prevent Modify Key 
Cycling

Not Used.

Print DOB on Journal Select to print DOB on journal logs.

Print DOB on Receipt Select to print DOB on receipt.

Print Receipt Select to print a receipt for every transaction (if not selected, a receipt will only print for No Sale, Pay 
In, Pay Out, Clock In/Clock Out, Void, Car Wash, POP Discounts, Credit Transactions).

Print UPC on Receipt When this feature is enabled, the actual UPC or PLU will be printed on the receipt, along with the 
description.

Prompt Dine In Select to prompt dine in for food orders.

Prompt Food Order 
Name

Enable to prompt for entering customer name for food orders.

Prompt Food Order 
Phone #

Enable to prompt for entering customer name for food orders.

Prompt Loyalty for PLU 
Not Found

When enabled, if a scanned bar code or manually entered number comes as “PLU Not Found”, the 
system asks the user if the number is a Loyalty Card. 

Receipt Print PPG 
Discount Table

Enable to print clearer breakdown of discounts on the fuel receipt. This includes pop, loyalty, and any 
other discounts taken off fuel prices.

Receipt Print Program 
Name

Receipt prints loyalty program name. 

Register Time-Out 
Timer

Enter the number of minutes (001 – 999) after which an idle terminal automatically switches out of 
Sales Mode. Entering 000 indicates that an idle terminal will not log out of sales mode.

Release Terminal 
During Close

Select to allow the terminal to return immediately to Sales mode after a close shift or close daily is 
started.

Reminder to Use 
Imprinter

Not Used.

Reset Display on 
Drawer Close

Idle sales message returns when the drawer closes.

Reset Display on 
Timeout

Enter the time (in seconds) before the idle sales message returns to the operator display after a 
transaction is complete. When “Reset Display on Time-out” is selected, a value must be entered here 
(2 – 3600). 1 = 2 seconds. 0 disables the option to reset display on time-out.
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Stack Manual Discount If enabled, multiple manual discounts can be applied on a line item. Cannot apply multiple discounts if 
item has NAXML discount applied to it.

Store Number Enter the number or name that identifies the store. This information is printed on receipts and reports 
(alphanumeric, 1 - 5 characters).

Value Added Tax (VAT) Select if value added tax (VAT) is collected at the site. Special prompts for VAT appear in the Tax Rate 
File (U.S. and Canadian sites usually do not collect VAT).

 

NOTE
See the Verifone Commander User Reference in the event the function is not listed above.      
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Login/Logout Message

The Sales Login/Logout Messages 
display a message when logging in or 
out of sales mode for the cashier to 
review. The messages only appear at 
the time of logging in or out of sales.

Messages will appear for all cashiers.
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Images

Users can upload images for menu items to different areas such as the Welcome screen.

1. Navigate to C-Site Management > Configuration > Site Management and then select a site. 

2. Navigate to Store Operations and then click on Images.

3. Use the search boxes to find the Image Name or Target. 

4. Click on Add to upload a new image. 
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5. Click on the information icon next to Image Upload for the image guidelines.

6. After reading the Guidelines, click Close. 
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7. Select target for the image upload and then click on Browse files. 

8. Select the image.
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9. Click Save and the system validates the image specific to the image guidelines. 
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Menus

Use Store Operations > Menus to view the menus. 

The Menus form allows the ability to view PLU items in menus and menus that are linked together in menu 
chains / order menus. Menus are assigned to the POS touchscreen, Self Checkout touchscreen, or to the 
register keyboard if one is used. 

The Menu Selector displays a list of existing menus sorted in the order of their Menu ID number. The menu 
selector displays the Menu ID number, Menu Name, and any Notes.

The note field displays additional information about the menu for configuration use only. The note is 
displayed in only in areas of the configuration such as menus, touchscreen configuration, 
self checkout configuration, etc. Notes appear in parenthesis to the right of the description.

 

NOTE
Menus requires Verifone Commander 56.00.00 and higher release version.

Menu Selector

Menu Items
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Field Description

Select Menu Type Select the menu type. These are the menu types:

Expanded Menu — Displays several PLUs and allows only one PLU to be selected. The menu clears 
after one selection. It is also known as single-select menu.

Multi-Select Menu — Displays items in the menu until “Done” is selected. 

Express Menu — Displays six items in an overlay or pop-up and the menu clears after one selection. It 
was previously known as Ruby menu.

Menu Chain and Order Menu — Both these menu types can be assigned one or more Expanded or 
Multi-selector Express menu types and when selected, leads to the other menus.

In the Order Menu, all menus are added as sub-items and treated as a single line item in the ticket. 
When voided, entire order will be removed from the ticket.

In the Menu Chain, each menu item is added as a separate line in the ticket and each item must be 
voided separately.

Search Menus The search menus field is a context sensitive search field that allows menus presented in the menu 
selector to be easily searched.

Menu Selector The menu selector displays the Menu ID number, Menu Name, Menu Type, and any Notes when used. 
The menu selector displays a list of existing menus sorted in the order of their Menu ID number. The 
user can go forward or backward through the selections. 

Number Displays the menu number. 

Name Displays the name of menu that will appear on the POS or Self Checkout.

Type Displays the type of menu. 

Note The note field is used to add additional information about the menu for configuration use only. The 
note is displayed only in areas of the configuration such as menus, touchscreen configuration, self 
checkout configuration, etc.

Parked It indicates if a menu is used in the parked menu panel of the POS screen. This option is not available 
for menu chains and order menus.

Menu Items Displays the PLUs in a menu with the number, UPC, display name and image. 

Filters Menu items can be filtered by UPC or name. The search can contain or not contain certain numbers or 
characters. 
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Touch Screen

Touch Screen is located under C-Site Management > Site Management > (Select Site) > Store Operations. 
Use the following sections to configure the screen panels. The Touch Screen is divided into three sections:

• Panels — The area within a screen with these panels is collectively referred to as User Panel.

• Screens — Each screen has a name and can be configured to have up to three panels. All screens 
appear as tabs on the register. A screen can have only one fuel panel and one parked menu panel. 
Also, only one fuel panel and parked menu panel can be assigned to a POS register, but these fuel 
panels and parked menu panels can be included in multiple screens on the register. 

• Registers — Each Register or POS can be configured to have one or more screens. 

Panels Configuration

Use Store Operations > Touch Screen > Panel Configuration to configure panels and to configure items 
assigned to panels. 

Panels have the following types:

• Item Panels

• Parked Menu Panels

• Fuel Panels

• Fuel Details

 

NOTE
Touch Screen requires Verifone Commander 56.00 release version.      
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Item Panels

Use Item Panels form to configure panels that have PLU, Department, MOP, Function or Menu Key items.

Field Description

Search Item Panel Search for an existing item panel.

Edit Panel Edit a selected panel

Select Item Panel Select the item panel to be edited, deleted, or copied. 

Delete Delete a selected item panel.

Copy Copy a selected item panel.

Add Add a new item panel.

Preview Preview the buttons on an item panel.
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View or edit an item panel

Click on Edit Panel. 
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View or edit an item panel (Continued) 

 

NOTE New functionality has been added in conjunction with Verifone Commander Release 56.00 
where the user can use drag and drop with panels, buttons, and screens.      

Field Description

Delete Item Select and delete an item from the panel.

Add Item Add an item to the panel using the Item Properties on the right side.

Name Name of the panel.

Platform Platform or POS used.

No of Rows Number of Rows used on the panel.

Utility Panel Check the box if this is a Utility Panel. 
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Item Properties Use to edit existing items or assign properties to new items.

Inactive - It defaults to inactive.

Item Type - Sets the item as a function, department, MOP, Menu, PLU, or Monitor. The next value 
input is assigned based on the item type.

Line 1 - Enter eight alphanumeric characters.

Line 2 - Enter eight alphanumeric characters. 

Text Color - Enter the Hex Color Code for the button label.

Background Color - Enter the Hex Color Code for the button color.

Item Position - Use the arrows to move the item around on the panel. Alternatively, use the mouse or 
mouse pad to drag and drop the item into a different location on the panel.

Also, the user can drag and drop the buttons as well from the screen.

Discard Remove any changes made to this form.

Save Save all changes made to this form. 
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Parked Menu Panels   

 

NOTE New functionality has been added in conjunction with Verifone Commander Release 56.00 
where the user can use drag and drop with panels, buttons, and screens.      

Field Description

Search Parked Menu Search for an existing Parked Menu.

Select Parked Menu Select a Parked Menu for editing. 

Assigned Register(s) Register or POS terminals assigned to the Parked Menu. 

Select Menu Add a menu to a Parked Menu. 

Text Color Enter the Hex Color Code for the button label.

Background Color Enter the Hex Color Code for the button color.

Delete Delete a selected Parked Menu.
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Add Add a new Parked Menu.

Preview Text Displays a preview of the menu button colors. 

Copy Select a Parked Menu the list and make a copy of it. 

Discard Remove any changes made to this form.

Apply Changes Save all changes made to this form. 
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Fuel Panels 

 

NOTE New functionality has been added in conjunction with Verifone Commander Release 56.00 
where the user can use drag and drop with panels, buttons, and screens.      

Field Description

Search Fuel Panel Search for an existing Fuel Panel.

Select Fuel Panel Select a Fuel Panel for editing. 

Assigned Register(s) Registers or POS terminals assigned to the Fuel Panel. 

Select Menu Add a menu to a Fuel Panel. 

Delete Delete a selected Fuel Panel.

Copy Select a Fuel Panel the list and make a copy of it. 
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Fuel Details

Add Add a new Fuel Panel.

Starting Fuel Point Enter the fueling point number where the fuel points should start on the fuel panel. 

Number of Fuel Points Enter the number of fueling points for the fuel panel. 

Fuel Point Assignments Use the mouse or mouse pad to drag and drop the fuel points into a desired order. 

Reset Click to set the fuel point assignments to the default order.

Discard Remove any changes made to this form.

Apply Changes Save all changes made to this form. 

Field Description

Search Prepay Profile Search for an existing Prepay Profile of Fuel Prepay Buttons. 

Select Prepay Profile Select the Prepay Profile to edit.

Assigned Register(s) Registers that are assigned to the selected Prepay Profile. 

Fuel Prepay Buttons Create preset buttons for certain amounts. 

Discard Remove any changes made to this form.

Apply Changes Save all changes made to this form. 
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Screens Configuration

Each screen has a name and can be configured to have up to three panels. A screen can have only one fuel 
panel and one parked menu panel, but these fuel panel and parked menu panels can be included in multiple 
screens on the register.   

Field Description

Search Screen Search for an existing created screen. 

View/Edit Screen Use to view or edit an existing screen from the selected screen on the left side. 

Select Screen Select the screen to edit.

Assigned Register(s) Registers that are assigned to the selected screen. 

Display Name Displays the name of the screen on a tab to the cashier. 

Panel Assignment Displays up to three panels with panel types and item panels. 

Delete Delete a selected screen.

Copy Copy a selected screen.

Add Add a new screen.
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Add a New Screen

To add a new screen, click Add. 
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NOTE New functionality has been added in conjunction with Verifone Commander Release 56.00 
where the user can use drag and drop with panels, buttons, and screens.      

Field Description

Screen Name Give the new screen a name. 

Platform Platform or POS used.

Utility Panel Check the box if this is a Utility Panel. 

Delete Panel Delete the selected panel.

Add Panel To add a panel, click Add Panel and then use the Panel Assignment to the right on the screen. There 
can only be three panels per screen.

Display Name It is the name of the screen that displays as a tab to the cashier on the POS. The cashier can switch 
back and forth between tabs.

Panel Assignment It configures the panel by type. Panels can be moved using the mouse or mouse pad. 

Panel Type The panel type can be configured by Fuel Panel, Item Panel, or Parked Menu Panel. There can only be 
one Fuel Panel and one Parked Menu Panel.

Item Panel Selection(s) After selecting Item Panel for Panel Type, select the items. 

Discard Remove any changes made to this form.

Save Save all changes made to this form. 
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View or Edit an Existing Screen

Click on View/Edit Screen on the Screen main form. 
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View or Edit an Existing Screen (Continued)

 

NOTE New functionality has been added in conjunction with Verifone Commander Release 56.00 
where the user can use drag and drop with panels, buttons, and screens.      

Field Description

Screen Name Select the screen to be viewed or edited.

Platform Displays POS platform.

Utility Panel Check the box if this is a Utility Panel. 

Delete Panel Delete the selected panel.

Add Panel Not used.

Display Name It is the name of the screen that displays as a tab to the cashier on the POS. The cashier can switch 
back and forth between tabs.

Panel Assignment It configures the panel by type. The user can also drag and drop panels. 

Panel Type The panel type can be configured by Fuel Panel, Item Panel, or Parked Menu Panel. 
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Registers Configuration

Use the Registers Option to assign fuel options and screens to each POS or register. 

Options 

Field Description

Search Option Search for an option that has fuel options assigned to it. 

Select Option Select the option to view or edit. 

Assigned Register(s) Registers that are assigned to the selected option.

Fuel Options These Fuel Options assigned to an option:

• Zoned Fuel Control - This function disables the approve all functionality.

• Allow One-Touch Approval - Allows the cashier to touch a fueling icon just once to approve a calling 
fueling position.

• Allow One-Touch Claim - Allows the cashier to touch a fueling icon just once to claim a due fuel 
sale.

Discard Remove any changes made to this form.

Apply Changes Save all changes made to this form. 
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Configurations  

Field Description

Search Resister Search for an installed register or POS.

View/Edit Register Use to view or edit an installed register or POS from the selected register on the left side. 

Select Register Select the installed register or POS to edit.

Assigned Register(s) Registers that are assigned to the selected screen. 

Display Name Displays the name of the screen. 

Panel Assignment Displays up to three panels with panel types and item panels. 

Delete Delete a selected screen.

Copy Copy a selected screen.

Add Add a new screen.
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View or Edit an Existing Register

Click on View/Edit Register or POS on the Register main form. 
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View or Edit an Existing Register (Continued)

  

 

NOTE New functionality has been added in conjunction with Verifone Commander Release 56.00 
where the user can use drag and drop with panels, buttons, and screens.      

Field Description

Register Name Select the Register to be viewed or edited.

Copy To Copy the selected register's touch screen configuration to another installed register or POS. Do not 
use the default register.

Tabs These are displayed to the cashier and added using the Screen Selection drop-down menu on the left 
side.

Platform Displays POS platform.

Utility Panel Check the box if this is a Utility Panel. 

Screen Selection This function adds screen tabs to allow the cashier to switch back and forth between screens.

Tab Screens can be dragged and 
dropped in a desired order.
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Fuel Panel Select and add a fuel panel from the drop-down menu to the screen. A screen can have only one fuel 
panel.

Parked Menu Panel Select and add a parked menu panel from the drop-down menu to the screen. A screen can have only 
one parked menu panel.

Fuel Details Panel Select and add a Prepay Profile from the drop-down menu to the screen. 

Fuel Options Select and add a Fuel Options profile from the drop-down menu to the screen. 
                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         144



                                                                                                                                Verifone C-Site Management User Guide
 

Tipping

Tipping is located under C-Site Management > Site Management > (Select Site) > Store Operations. The 
Verifone Commander now provides flexible tipping options for sites that sell prepared items. The tipping 
prompt will be displayed on the PIN pad. Preset amounts or percentages for customer selection will be 
configured in Verifone C-Site Management. The “Prompt for Tip” will be enabled in the department and will 
apply to all PLUs within that department. Customers will have the option to enter a custom amount. The 
prompt is customizable.

Navigate to Store Operations > Tipping to view the configuration. 

 

NOTE

Tipping requires Verifone Commander 56.01 release version.
See the Tipping Feature Reference on how to configure the Tipping feature on Verifone 
C-Site Management.
The Tipping Feature can only be configured on Verifone C-Site Management. It is not 
available in Verifone Configuration Client.       
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House Accounts

House Accounts is located under C-Site Management > Site Management > (Select Site) > Store 
Operations. A House Account is a non-network, local store account that is set up with credit granted at the 
discretion of the site manager. House accounts require an account number, which prints on the receipt. 
Verifone Commander keeps and reports totals for House accounts but does not keep records of individual 
transactions or balances. Follow store policy to manually record transactions.

1. Navigate to Store Operations > House Accounts.

 

 

NOTE
House Accounts requires Verifone Commander 56.03.00 and higher release version.

Field Description

Search Bar Search by account number or house account name.

Add Click to add a new house account.

Delete Click to delete a house account.

Copy Click to copy an existing account settings currently displayed and then add a new account number.
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2. Click Add.

Field Description

Account Number Enter the account number. (Alphanumeric, 1-+20 characters)

Account Name Enter the name of the customer. (Alphanumeric, 1-+20 characters)

Enable Select to enable the house account.

Prompt for SubAcct# Enable to prompt for sub account number.

In-House MOP Prompt for “House Account? [Y/N] when an In-House MOP is used in a transaction.

Pay IN Function Prompt for “House Account? [Y/N] when the Pay-In function is used in a transaction.

Pay OUT Function Prompt for “House Account? [Y/N] when the Pay-Out function is used in a transaction.

Discard Discard changes made to this section. Displays when a change is made on the screen.

Apply Changes Apply changes made to this section. Displays when a change is made on the screen.
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Charity Donations

Charity Donations is located under C-Site Management > Site Management > (Select Site) > Store 
Operations. The charity donation feature enables a customer to donate certain amount to a charity. The 
system prompts customers during tendering process for charity donation. Customers are asked if they wish 
to make a charity donation. When the customer is using Cash as MOP there are two options that can be 
enabled from configuration client to be presented to the customers on the PIN pad: 

• Donate change amount (rest for charity) and is calculated as the difference between the amount 
due and the amount paid.

• Round to next dollar amount which rounds off their transaction to the next whole dollar. The 
donation amount is the difference between the total amount of the purchase and the rounded dollar 
amount.

 

NOTE
Charity Donations requires Verifone Commander 56.03.00 and higher release version.
                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         148



                                                                                                                                Verifone C-Site Management User Guide
 

  

Field Description

Enable Enables the Charity Donations program.

Department Select the charity department. 

Note: If the charity department does not have a NACS product code 
971 assigned, it will not appear in the department drop-down in this 
form.

Cash Payment Options

(Inside Only)

Rest for Charity Enable this option for cash payments. It donates the remaining 
change amount for charity.

Round to next dollar Enable this option for cash payments. Rounds off the transaction to 
the next whole dollar. The donation amount is the difference 
between the total amount of the purchase and the rounded dollar 
amount.
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Network Payment Options Round to next dollar Enable this option for Network Payments. Rounds off the transaction 
to the next whole dollar. The donation amount is the difference 
between the total amount of the purchase and the rounded dollar 
amount.

Enable Preset Amount 3 Enable the third preset amount.

Prompt Outdoor Enable to prompt for charity donation outside.

Preset Amount 1 Enter the preset amount option 1.

Preset Amount 2 (Outside Only) Enter the preset amount option 2. This option is only available for 
outside transactions.

Preset Amount 3 Enter the preset amount option 3.

Discard Discard changes made to this section. Displays when a change is 
made on the screen.

Apply Changes Apply changes made to this section. Displays when a change is 
made on the screen.
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Promos and Discounts
To configure Promos and Discounts at a site, navigate to C-Site Management > Configuration > Site 
Management and select a site. Use the following section to configure the Promos and Discounts.

Car Wash PLU Promotions

Car Wash PLU Promotions is located under C-Site Management > Site Management > (Select Site) > 
Promos and Discounts. Car wash discounts are set up as promotional items. This means that if the 
customer purchases a car wash and has met the criteria for the promotional price, then the correct price is 
automatically applied after the cashier presses [TOTAL].  

If the discount is set for the same price as the car wash item and the purchase requirements are met, then 
the car wash is free. The customer must request the car wash and the cashier must enter it into the 
transaction. The car wash promotion prints on the receipt and on the journal. 

Whether or not a car wash discount is available depends on three conditions: 

• The type of discount that has been set up.

• Whether the customer prepays or postpays for the fuel.

• When the customer requests the discount.

 

NOTE Until the cashier press [TOTAL], the Operator Display and the Customer Display show the 
running total with the undiscounted price for the car wash.
                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         151



                                                                                                                                Verifone C-Site Management User Guide
 

 

Field Description

Search Bar Search for the PLU using the UPC number.

Add Click to add a new PLU number.

Delete Click to delete an existing PLU numbert.

Copy Click to copy an existing PLU settings currently displayed and then add another PLU number.
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Field Description

Search PLUs Enter the PLU number to which the promotion applies. Do not enter 
leading zeros. 

PLU It is an item or service that uses a Universal Product Code (UPC).

Start Date/Time Enter the date the promotion starts. 

End Date/Time Enter the date the promotion ends. 

Discount Type Amount Enter the amount of the discount for the promotion.

Percent Enter the percent of the discount for the promotion.
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Discount Requirements None Select if there are no discount requirements.

Minimum Ticket Purchase 
Amount

Click if the customer is required to purchase a car wash for a 
minimum amount to qualify for the promotion discount. Enter the 
minimum dollar amount in the Purchase text box.

Minimum Fuel Product 
Amount

Click if the customer is required to purchase a minimum dollar 
amount of a specific fuel product to qualify for the promotion 
discount. Enter the minimum dollar amount in the Purchase text box 
and the fuel product ID in the Fuel Product ID drop-down menu.

Minimum Fuel Volume Click if the customer is required to purchase a minimum quantity of 
fuel to qualify for the promotion discount. Enter the minimum 
quantity in the Purchase text box.

Discard Discard changes made to this section. Displays when a change is 
made on the screen.

Apply Changes Apply changes made to this section. Displays when a change is 
made on the screen.
                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         154



                                                                                                                                Verifone C-Site Management User Guide
 

Payment Operations
To configure Loyalty, Mobile Payment, Commercial Fleet Direct, or Primary Payments at a site, navigate to 
C-Site Management > Configuration > Site Management and select a site. Use the following sections to 
configure the Payment Operations.
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Loyalty

Loyalty Sales allow the processing and redemption of loyalty transactions, both inside at the Point of Sale 
(POS) and outside at the Dispenser Card Readers (DCR). Each locations loyalty configuration can be viewed 
and modified for individual sites. The individual site configuration for loyalty is found under C-Site 
Management > Site Management > Site Name > Payment Operations > Loyalty.

Complete the following parameters shown specific to the Loyalty Host being configured. See table below 
for details on each field.

Parameters

Field Description

FEP Enabled Enables the loyalty program.

Provider Select the loyalty provider from the list that is used to host the name. The list is a predefined selection 
of approved loyalty hosts.

Merchant ID Sets the Merchant ID provided by the network.
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Cards

Program Name Sets the Program ID for the loyalty program.

IP/Host Sets the IP address of the loyalty host. (Provided by loyalty host)

Port Communication Port Number for the primary loyalty host. (Provided by loyalty host)

Heartbeat (Seconds) Sets the interval in seconds between network status checks from the Electronic Payment Server to 
the Loyalty Host. Minimum amount allowed is 120 seconds.

Enable TLS Enables the use of a secure Transport Layer Security (TLS) connection to the loyalty host. When TLS 
is used, data is encrypted over the communication line.

Enable Barcode Scan Enables a Barcode Scanning for the related FEP. The flag default is disabled.

Enable Card Download Enables the Loyalty Card Table Download that allows the Loyalty Host to send down card table 
entries. The flag default is disabled.

Display FEP Inside for 
Multiple Loyalty

Displays Loyalty Program at the POS when multiple loyalty is used.

Display FEP Outside for 
Multiple Loyalty

Displays Loyalty Program at the DCR when multiple loyalty is used.

Receipt Offline 
Message

When loyalty is offline, the message entered here will print on the receipt.

Remove Program Removes the loyalty program.

Field Description

Card Name Name given to identify this entry.

Abbreviation Sets a two digit abbreviation for the card.

Lower ISO Sets the lower value of the card (BIN) range. The entered card number must be greater than or 
equal to this number to match the table entry.

Upper ISO Sets the upper value of the card (BIN) range. The entered card number must be less than or equal 
to this number to match the table entry.
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General Settings

1. To view or edit individual site loyalty configurations navigate to C-Site Management > Configuration > 
Site Management 

2. Use the search by Site name or Hierarchy drop-down menu to locate the site you wish to modify the 
loyalty configurations for. After the site name is located, click on the name to open the site 
configuration. 

3. Select Payment Operations > Loyalty from the left column to view the site’s loyalty parameters.

4. To view the site’s general loyalty settings, use the drop-down menu on the top left column to switch 
from the loyalty programs to General Settings. 

PAN Length Sets the number of digits to be used with the card.

Hybrid Sets the card as a hybrid card.

Field Description

Enable Alternate ID Enables the payment device to prompt for an alternative ID for loyalty.

Prompt for Loyalty after 
payment

Prompts the customer for loyalty after they have paid for the transaction.

Display Host Messages Loyalty messages will appear on the POS from the loyalty host.
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5. Loyalty Programs (PCATs Loyalty in Verifone Commander’s Configuration Client) assigned to the site 
will be found under the Programs drop-down menu. 

If the loyalty program is managed through Enterprise configuration, then it will have a label next to the 
program name indicating ‘Enterprise’.

Journal Loyalty ID to 
POS

Captures the customer’s loyalty ID in the site’s POS journal logs. 

Send Reward prompt 
to Cashier

Enables the cashier to answer the PIN pad prompt from the POS in the event the customer hands the 
cashier cash and leaves the store without using the PIN pad display. 

Reward Prompt 
Timeout (in seconds)

Sets a time out value for the loyalty reward prompt in seconds. 

Use Long Test for 
Indoor Prompts

Shows longer prompts inside for loyalty rather than abbreviating them.

Prompt for reward on 
fuel only

Enabling this setting will only prompt the customer for loyalty if they are purchasing fuel.
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Mobile

Individual site configurations for mobile payments is found under C-Site Management > Configuration > 
Site Management > Site Name > Payment Operations > Mobile. 

Edit Site Details

1. To edit site mobile configurations, navigate to C-Site Management > Configuration > Site 
Management > Select the Site Name from the list. 

2. Select Payment Operations > Mobile.

3. The Site Settings are presented by default. Complete the following parameters shown specific to the 
Mobile Payment Host being configured. See table below for details on each field.

Field Description

Enable Mobile 
Payments

Enable to accept Mobile Payments.

Welcome Message The site’s welcome message (100 characters).

Data Storage Time The Data Storage Time for retention (0-30 days).

Report The Mobile Terminal Batch Detail Report is the only report for the format type below. 
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Edit Program Details

1. To edit site mobile configurations, navigate to C-Site Management > Configuration > Site 
Management > Select the Site Name from the list. 

2. Select Payment Operations > Mobile.

3. The Site Settings are presented by default. To modify the programs, switch the drop-down menu to 
Program List.

4. Use the Select Program drop-down menu under Program List to modify any site specific MIDs. They 
must have the checkbox enabled to add any site specific details.

Format The combination of these fields are used to set the format type for each report from the report 
drop-down menu.

The values are “Standard” and “Extended Authorization.”

The default format type would be “Standard” for all reports.

In the Chevron distribution, the Mobile Terminal Batch Detail Report will default to Extended 
Authorization format.

Standard: In this format max limit for authorization number is 14 digits and first 14 digits gets printed.

Extended Authorization Format: Min limit for authorization number is 1; no upper limit.

As of now, this feature is applicable only for Mobile Terminal Batch Detail Report.
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5. Use the (+) next to the MID to add additional details such as Store ID, Settlement Employee Number, 
Settlement Passcode, and Phone Number. See table below for details on each field.
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Copy Mobile Configuration

1. To edit site mobile configurations, navigate to C-Site Management > Configuration > Site 
Management > Select the Site Name from the list. 

2. Select Payment Operations > Mobile.

3. Click Copy Mobile Configuration from the top right corner of the screen. 

4. A list of sites will appear to select a location to copy the configuration from. Use the Hierarchy drop-
down menu or the search by name function to narrow down the site. Select the site you want to 
copy the Mobile Program from.

Field Description

Store ID The Store Identification (ID) Number.

Site Terminal ID It is the ID number for the terminal received from the mobile payment host.

Settlement Employee 
Number

It is the number used by the Verifone Commander for settlement with Mobile Payment Host. The 
Settlement Employee Number is provided by the Mobile Payment Host.

Settlement Passcode It is the Passcode used during settlement assigned by Mobile Payment Host.

Phone Number Store Phone Number.
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5. The copy form will open after the site is selected. The MIDs are copied from the store selected on the 
previous screen, along with their configurations. Make sure you click the Select Program button to edit 
and update the MIDs for the location. 

6. Selecting the + next to the MID will allow entry of additional configuration parameters: Store ID, 
Settlement Employee Number, Settlement Passcode, and Phone number. See table below for details 
on each field.
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7. After all changes are made, select Apply changes.

Disable Mobile Payments for an Individual Site

1. To edit site mobile configurations, navigate to C-Site Management > Configuration > Site 
Management > Select the Site Name from the list. 

2. Select Payment Operations > Mobile.

3. Deselect the Enable Mobile Payments check box. 

Field Description

Store ID The Store Identification (ID) Number.

Site Terminal ID It is the ID number for the terminal received from the mobile payment host.

Settlement Employee 
Number

It is the number used by the Verifone Commander for settlement with Mobile Payment Host. The 
Settlement Employee Number is provided by the Mobile Payment Host.

Settlement Passcode It is the Passcode used during settlement assigned by Mobile Payment Host.

Phone Number Store Phone Number
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4. Click Apply changes in the bottom right corner. 

Mobile Payment Configuration Troubleshooting

• Mobile Site Configuration Not Found — If the site is Active, confirm they are on Release 53.41 
software or higher. Site Assets can be checked under Reports > Site Assets. Search for the Service 
ID of the location and then confirm the Verifone Commander’s Software Release is showing 53.41 or 
higher.

• Mobile Payment Program Adapter is Blank — The Mobile Payment Program Adapter selection only 
supports VFI Mobile 1 and VFI Mobile 2. If the program was imported from a site that had FDC 
Mobile or Local MPPA was selected, then the field will be blank in the Mobile Payment Program after 
it is imported.
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Commercial Fleet (Direct)

This section provides detailed information on how to configure and use fleet cards for use on the Verifone 
Commander and C18. The individual site configuration for Commercial Fleet is found under 
C-Site Management > Site Management > Site Name > Payment Operations > Commercial Fleet.

1. Click on the provider.  

2. Key in the Merchant ID.

3. Key in the IP/Host.

4. Key in the Port. 

5. Check or uncheck the Enable TLS box. 

  

NOTE

Site level “Commercial Fleet Direct”' configuration can be performed here. Multi-Site 
configuration will be supported in the future.
The Commercial Fleet for ExxonMobil is configured in Verifone Configuration Client.

  

NOTE    Currently, Comdata and WEX-OTR are the only providers.
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6. Click on Apply Changes or Discard to remove changes. 

7. Select General Settings from the drop-down menu in the upper right hand corner. 

8. Check or uncheck the Enable Cash Advance box. 

9. Key in the Cash Advance Limit.

10. Select the assigned Fuel Grade for Diesel. 

11. Click on Apply Changes or Discard to remove changes.
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Primary Payment

Card Price Tiers

Field Description

Search Cards Use search box to find a card.

Select Card Use the scroll bar to select a card to assign a Price Tier.

Card Name Displays the selected card.

Price Tier Assigns “Cash” or “Credit” to the card selected.
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Cashback & Fees

Field Description

Cashback Enabled Enables cashback on cards.

Force PIN Entry Enforces the customer to enter a PIN.

EMV Cashback 

Prompt – Wait for 

Cashier?

Displays “Wait for Cashier” prompt during EMV Cashback transactions.

Cashback Fee Sets the fee associated with cashback on MOP transactions.

EBT Cashback 

Enabled

Enables cashback on EBT transactions.

Enable Convenience 

Fee

Enables the fee for convenience. 

Fee Amount Sets the convenience fee amount. 
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Access Control

POS Security

The POS Security section is located under C-Site Management > Site Management > (Select Site) > 
Access Control. POS Security is used for creating POS users, such as cashiers, and controlling their access 
levels to functions within the POS. Changes made at the site will sync with the dashboard, and changes 
made within Verifone C-Site will sync with the store after saved.

Employees

The Employees tab is used to add new employees who can access the point of sale. The ID number 
assigned to the employee will be entered into the POS at the time of login along with the password.

Field Description

Search Employees Allows for employees to be searched by their name or exact ID number entered.

Select Employees Displays a list of existing employees.

ID The number entered in when a cashier or store personnel log into the register. The ID assigned must 
be a unique number from 1-2000. 

Name Used to identify the POS user/employee.
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Security Controls

Security Level A value between 0 and 9 that defines what areas the employee has access to on the point of sale. 
The level of 9 provides the most access to areas within the POS. Specific details on what security 
levels are required for functions on the POS can be found within the Security Controls tab and the 
Sales Functions tab. 

New Password / 
Confirm password

The password used when the employee logs into the POS. The value can letters and numbers.

Employee Number The employee number is a required field. This number is used for payroll reports. 

Can Cashier Enabling the Can Cashier check box allows the employee to log into sales mode (CSR Functions) on 
the register. If this option is disabled, they will not be able to log into the register and ring in sales.

Field Description

Select Menu ID Allows the category 

Select SubMenu ID Allows further filtering of specific security controls within a selected security control menu ID. This 
field will vary depending upon the Select Menu ID options.

Description & Security 
Level Table

Shows the description of the security function along with the minimum required security level to utilize 
that function. 

Apply All / Security 
Level Function

The security level drop-down menu and Apply All button allows the security level for all the displayed 
security controls to be changed in bulk to the selected Security level. Select the Security level from 
the drop-down menu and select Apply All to see the change. Select Apply Changes on the form to 
save the changes. Use Discard to clear any changes made.
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Sales Functions

Functions that are tied to sales are separated into the Sales Functions tab. Options such as Error Correct, 
No Sale, Suspend, and Price Override can be found here. If the security level is 0, then all users with the 
cashier checkbox enabled can perform the function. 

The security level drop-down menu allows a security level to be set for all sales functions shown. An 
additional search box allows the functions to be filtered down searching for the first letter of the 
description. For example, typing A will display apply updates.
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Forecourt

DCR Configuration

Receipt Settings
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Receipt Header

1. Key in up to 20-characters for each of the five available text lines for the Receipt Header. It will be 
displayed on the form on the right side of the page.

2. For the Receipt Header alignment, select Left, Center, Right.

3. Click the circled ‘X’ to delete the available text line.

4. Click ‘Add’ to enable the displayed text. 

Field Description

Always Print Receipt Receipt prints always after fueling. If disabled, the customer will be prompted to print the receipt. 

Receipt Prompt Before 
Sale

Customer will be prompted for a receipt before fueling. 

Receipt Prompt After 
Sale

Customer will be prompted for a receipt after fueling. 

Low Paper Alarm Alerts the cashier when the DCR is low on receipt paper.

Prompt Prepay Receipt 
Outside

Customer will be prompted for a receipt at the DCR after prepaying inside.

Discard Discard changes made to this section. Displays when a change is made on the screen.

Apply Changes Apply changes made to this section. Displays when a change is made on the screen.
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Receipt Trailer

1. Key in up to 20-characters for each of the five available text lines for the Receipt Trailer. It will be 
displayed on the form on the right side of the page.

2. For the Receipt Trailer alignment, select Left, Center, Right.

3. Click the circled ‘X’ to delete the available text line.

4. Click ‘Add’ to enable the displayed text. 
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Prompt Settings

Field Description

Handle Up Alert 

Message (In 

Seconds)

Amount of seconds the Handle Up Alert displays on the POS for the cashier when the dispenser 

handle is removed with no activity.

Error Prompt Time 

(In Seconds)

Amount of seconds an error prompt on the DCR.

Info Prompt Time 

(In Seconds)

Amount of seconds the last message displays on the DCR.

User Prompt Time 

(In Seconds)

Amount of seconds user input is required for DCR prompts.

Enable Keypress 

Beep

Enables a beep on the DCR for keypresses. This only applied to Wayne and Tokheim DCRs. 
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Enable Attention 

Beep

Enables a beep to get the attention of the customer. This only applies to Wayne, Gilbarco, and 

Schlumberger DCRs. 

Enable Mistake Beep Enables a beep when the customer presses an incorrect button selection. This only applies to 

Wayne, Gilbarco, and Schlumberger DCRs.

Pay Inside Cash/

Credit Prompts

Enables Pay Inside Cash/Credit Prompts to be displayed on the DCR.

Audible Help 

Message On POS

Enables an audible help message on the POS when pressed at the DCR. 

Discard Discard changes made to this section. Displays when a change is made on the screen.

Apply Changes Apply changes made to this section. Displays when a change is made on the screen.
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Other Settings

Field Description

Approve All Sales If enabled, cashier can approve all outside sales. 

Allow Fill-Up with 
Preset

Enable to allow the transaction to show the preset amount for fueling before the customer begins 
dispensing fuel. The amount can be changed by the customer.

Armed Forces 
Restriction

If enabled, DCR displays the Armed Forces prompt “Are you authorized [Y/N]?” prior to dispensing.

Discard Discard changes made to this section. Displays when a change is made on the screen.

Apply Changes Apply changes made to this section. Displays when a change is made on the screen.
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DCR Settings

Field Description

DCR Promo Message Key in the text for the customer to view while they are fueling. 

Add Click ‘Add’ to enable the DCR Promo Message.

Delete Click ‘Delete’ to remove the DCR Promo Message.

Attended Idle Screens Use the drop-down menu to select “Attended Idle Screens” for adding new or selecting saved 
screens. 

Unattended Idle 
Screens

Use the drop-down menu to select “Unattended Idle Screens” for adding new or selecting saved 
screens.
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Search By Name Use the search box to find saved idle screens. 

Select Attended 
Screen

Click on the desired DCR idle screen name in the list. 

Name Key in the text for the new DCR idle screen or edit an existing one.

Copy Screen Use the “Copy Screen” button to make a copy of the selected or newly created DCR idle screen. 

Assigned Position DCRs that are assigned the selected idle screen. 

Graphic Enabled Enable if the DCR has a graphic interface. 

Text Lines 1-4 Key in the text to be displayed on the DCR idle screen.

Discard Discard changes made to this section. Displays when a change is made on the screen.

Apply Changes Apply changes made to this section. Displays when a change is made on the screen.
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Key Configuration

Field Description

Search Key Name Search by keying in the name of the DCR keypad layout. 

Select Key Name Select the DCR keypad to make changes.

Name This is the name of the DCR keypad layout.

# of rows Select the desired number of supported rows for the DCR keypad layout.

# of columns Select the desired number of supported columns for the DCR keypad layout. 

Enable Alphanumeric Select to enable a DCR to allow alphanumeric keys. 
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Assigning an MOP to a DCR Key

1. Click on the desired key and three drop-down menus display on the left side of the keys.

2. Click on the Key Type drop-down menu. 

3. Select “Payment.” 

Discard Discard changes made to this section. Displays when a change is made on the screen.

Apply Changes Apply changes made to this section. Displays when a change is made on the screen.
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4. Click on the Key Code drop-down menu. 

5. Select the desired MOP Key Code from the Payment Key Code drop-down menu.

6. Click Apply to enable changes or Discard to remove changes.
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Assigning a Combination to a DCR Key

1. Click on the desired key and three drop-down menus display on the left side of the keys.

2. Click on the Key Type drop-down menu. 

3. Select “Combination.”
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4. Click on the Key Code drop-down menu. 

5. Select the desired Combination Key Code from the Combination Key Code drop-down menu.

6. Click on the Idle Function drop-down menu. 
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7. Select the desired Loyalty function or leave as Unused.

8. Click Apply to enable changes or Discard to remove changes.

Assigning a Function to a DCR Key

1. Click on the desired key and three drop-down menus display on the left side of the keys.
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2. Click on the Key Type drop-down menu. 

3. Select “Function.”

4. Click on the Key Code drop-down menu. 

 

 

 

                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         188



                                                                                                                                Verifone C-Site Management User Guide
 

5. Select the desired Function Key Code from the Function Key Code drop-down menu.

6. Click on the Idle Function drop-down menu. 
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7. Select the desired Loyalty function or leave as Unused.

8. Click Apply to enable changes or Discard to remove changes.

Assigning a Numeric to a DCR Key

1. Click on the desired key and three drop-down menus display on the left side of the keys.

2. Click on the Key Type drop-down menu. 
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3. Select “Numeric.”

4. Click on the Key Code drop-down menu. 
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5. Select the desired Numeric Key Code from the Numeric Key Code drop-down menu.

6. Click on the Idle Function drop-down menu. 
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7. Select the desired Loyalty function or leave as Unused.

8. Click Apply to enable changes or Discard to remove changes.
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DCR Settings > Position Settings
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Select DCR Position

Screen Settings

Payment Settings

Field Description

Select DCR Position Select a DCR position to apply the position settings.

Copy To Select one or multiple DCR Positions to apply the same settings to each one. 

Add Click on Add to apply the settings to the DCR position(s). 

Delete Click on Delete to remove the settings from the DCR position(s).

Field Description

Enable Graphic 
Support

Enable if the DCR supports graphics.

Graphic Keypad Enable if the DCR has a graphic keypad.

Graphic Printer Enable if the DCR has a graphic printer.

Attended Idle Screen Select the Idle Screen that the customer or attendant will see when used in Attended Mode.

Unattended Idle Screen Select the Idle Screen that the customer will see when used in Attended Mode.

DCR Key Select the DCR Key layout.

Graphic Display Select ‘Monochrome’, ‘Color’, ‘ROM’, or ‘Monochrome + ROM’ for the Graphic Display.

Graphic Screen Size Select the supported size between 5” to 12” for the Graphic Screen Size.

Graphic Text Lines Select between ‘1’ to ‘4’ lines or ‘full screen’ for the Graphic Text Lines. 

Field Description

Enable EMV Select to allow EMV at the DCR.

Pay At Pump Select if the pump has a DCR and is available for use.

Enable Debit Select to allow Debit at the DCR.

IP Address Enter the IP Address for DCR Communication.

Port Enter the Port number. 

Contactless Mode Select to enable ‘Contactless MSD’, ‘Contactless EMV’ or ‘Contactless Disabled’ Mode.
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Advanced Settings

Field Description

Push To Start Button Ensures that the correct instructions display on the DCR.

Grade Select Button Customer must press a corresponding fuel button when a pump dispenses multiple fuel products 
from a single hose.

Lever On Pump Select to enable the DCR prompts to display instructions for starting to fuel from dispensers with or 
without a lever.

Enable Scanner Select if the DCR has a scanner and is available for use. 

Menu Capable Select if the DCR position has graphics.

Primary Graphic Side Gilbarco Only. Enter the position number of the DCR that operates the graphic for both sides of a 
pump.

Discard Discard changes made to this section. Displays when a change is made on the screen.

Apply Changes Apply changes made to this section. Displays when a change is made on the screen.
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Fuel

Fuel Prices

Location fuel prices can be modified by selecting the Pending Prices option on the right side of the screen. 
Prices that are currently active at the store will be found by selecting ‘In Effect Prices’.

Fuel prices are set based on the products and service levels assigned at the location. If there is uncertainty 
which products are assigned at the dispensers, see the Fuel Configuration – In Effect tab > Fuel Positions. 

After the product is selected, the price can be changed for all the service level and MOP options by entering 
in an amount in the ‘Apply to all the Tier One (Two) Prices’ field and selecting Apply. Prices can also be 
entered in for each Service Level and MOP.

The Minimum Street Price is currently a read only field and sets the minimum amount that fuel prices can be 
set to. This field is intended to prevent incorrect fuel prices from being assigned. 

Select Apply Changes on the bottom of the page to save the updates. Select Discard to undo any changes 
made.
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Fuel Configuration 

The Fuel Configuration area is read only shows the Fuel Configuration that is ‘In effect’ at the site. Fuel 
configuration is set up at the time of installation by a Verifone Authorized Service Contractor (VASC). 

 

CAUTION Modifications to the store's fuel configuration can negatively impact site functionality. 
Consult the Verifone Helpdesk or a Verifone Authorized Service Contractor (VASC) prior 
to making changes.        
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Fuel Tax Exemptions

The Fuel Tax Exemption section is located under C-Site Management > Site Management > (Select Site) > 
Forecourt. Fuel Tax Exemptions are used to configure tax exemptions on fuel sales that can be applied to 
post pay fuel sales. The Fuel Tax Exemption configuration form allows up to five fuel tax exemptions to be 
entered. The exemption can be based on an amount per gallon, tax rate configuration, or both. 

Field Description

Fuel Tax Exempt 

Record ID

A record number must be entered from 1-5 for the fuel tax exemption.

Name Enter a description for the fuel tax exemption. 

Amount Enter the amount for fuel tax exemption if amount per gallon or both are selected for the Type drop-

down menu.

Type Select between Amount Per Gallon, Tax File Entry, or both to determine how the tax exemption is 

applied. If Tax File Entry or Both are selected, a tax will need to be selected from the tax drop-down 

menu.

Print Receipt Line 

(Signature Line)

Determines whether the fuel tax receipt lines configured will print with the sale or not. 

Fuel Tax Receipt Line Allows the receipt printed for transactions with fuel tax exemption to include specialized receipt 

information. 
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Car Wash

The Car Wash section is located under C-Site Management > Site Management > (Select Site) > Forecourt. 
Car Wash feature is used to buy a Car Wash by different methods, at the POS, at the dispenser or at the car 
wash controller (if the site has the option available). When a customer purchases a car wash the system 
that is used for the purchase is forced to print a receipt because it prints the Car Wash code on the receipt. 
Car Wash code is entered at the Car Wash Controller when the customer decides to redeem the code for 
the Car Wash.

When Car Wash is integrated with Verifone Commander™ Verifone Commander the following is some 
information on how this works:•

• Car Wash “items” must be sold as PLUs.

• Car Wash items can be sold at POS or at dispenser where consumer is led through the required 
steps for purchase.

• Car Wash code (for redeeming the car wash) prints on the receipt and so ticket printing is forced.

• The PLU Promotions feature may be used to automatically discount Car Wash when the configured 
requirements for fuel purchased in the same transaction are met.
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Field Description

Enable Car Wash Select to enable car wash.

Department Select the department used for car wash from the drop-down menu.

Days Car Wash Code is Valid Enter the number of days a car wash code is valid. A zero value 
denotes non-expiring card wash code. An expiration message is not 
printed on the receipt if the value is zero.

Display Order (by Expense) Select ‘None,’ ‘Ascending,’ or ‘Descending’ (according to price) to 
establish the order in which car washes appear on the DCR display.

Car Wash DCR Attributes Prompt at Beginning of 
Sale

Select to prompt for a car wash before the customer begins fueling.

Prompt at End of Sale Select to prompt for a car wash after the customer has finished 
fueling.

Menu Presentation Select to display the car wash prompt in menu form. The customer 
can choose a car wash item by keying the item number and pressing 
[ENTER] on the DCR keypad. (If not selected, the car wash prompt 
displays in a series of Yes/No questions.)

Car Wash Key Setup PLU Displays the PLU number of the car wash.

Modifier Displays the modifier for the PLU.

Search Plus Search for existing PLU to add to Car Wash Key Setup

Outdoor Select the car washes that can be purchased at the DCR.

Add PLU Adds placeholders for additional PLUs in the Car Wash Key Setup.

Discard Discard changes made to this section. Displays when a change is 
made on the screen.

Apply Changes Apply changes made to this section. Displays when a change is 
made on the screen.
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Fuel Price Display

The Fuel Display section is located under C-Site Management > Site Management > (Select Site) > 
Forecourt. The Fuel Price Display Configuration form is used to set up and edit the Fuel Price Display sign for 
the requirements of the site. 
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Field Description

Site Parameters Delay Pump [0-300 secs] When a fuel product price is decreased using the Forecourt > Fuel > 
Fuel Prices – Pending form, the decreased price is first sent to the 
pump and then the Fuel Price Display as a result there is a delay at 
the Fuel Price Display to show the decreased price. The Delay Pump 
parameter is used to delay showing the increased price at the pump 
so that at both the places the changed prices can appear almost at 
the same time.

Delay Sign [0-300 secs] When a fuel product price is increased using the Forecourt > Fuel > 
Fuel Prices – Pending form, the increased price is first sent to the 
Fuel Price Display and then the pump as a result there is a delay at 
the pump to show the increased price. The Delay Sign parameter is 
used to delay showing the increased price at the Fuel Price Display 
so that at both the places the changed prices can appear almost at 
the same time.

Channel Channel List Select the fuel price display channel.

Copy To Copy displayed configured channel to other channels.

Enable Channel Select to enable the Fuel Price Display feature.

Product Mapping Fuel Price Display ID Select the ID number that maps to the fuel price line on the 
Electronic Sign and then select Enable. (Follow the Fuel Price Display 
sign manufacturer’s guidelines for IDs.) 
Note: The fuel prices that display is set in Forecourt > Fuel Prices. If 
tier pricing is in effect, the Fuel Price Display price is the current tier 
price.

Enable Select to enable Fuel Price Display.

Fuel Product In the Fuel Product list, select only the fuel product(s) to be displayed 
for the fuel price display ID.

Service Level Select the service level — Self, Full, Mini.

Price Level Select the price level — Cash, Credit, Check.

Implied Decimal For most U.S. sites, select 3. For information, see the Verifone 
bulletin for your Fuel Price Display sign.
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Fuel Price Display Text Text Lines Enter text to display on the Fuel Price Display sign (alphanumeric, up 
to 128 characters). HTML text attributes may be used. For 
information, see the Verifone bulletin for your Fuel Price Display sign.

Add Adds placeholders for additional PLUs in the Car Wash Key Setup. 
Up to ten can be added.

Select to delete a line.

Discard Discard changes made to this section. Displays when a change is 
made on the screen.

Apply Changes Apply changes made to this section. Displays when a change is 
made on the screen.
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15 MAJOR OIL POLICY

Major Oil Policy is a framework that allows Major Oils to enforce specific configuration settings across their 
sites. For example, they can mandate that mobile payment is enabled as a method of payment at all 
locations under their brand.

As of release v1.23, C-Site Management supports only predefined (canned) policy enforcements. This 
release includes two such policies:

• Mobile MOP – Ensures mobile payment is configured.

• DCR Idle Screen for Loyalty Manual Entry – Controls the display behavior on the dispenser. 

Current Major Oil Policies 

  

NOTE Only certain field(s) will be controlled in a form corresponding to a policy.

Policy Description

Mobile MOP Ensures mobile payment is configured.

DCR Idle Screen for Loyalty Manual Entry Controls the display behavior on the dispenser.
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Website URL 
To access Verifone C-Site Management, navigate to the following URL using a web browser:

https://us.live.verifone.cloud/
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Major Oil Welcome Page
After the Major Oil logs in, the Welcome Page Displays. 
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Dashboard
This section discusses the Verifone C-Site Management application Dashboard. The dashboard provides 
information on online sites, offline sites, latest sites added, pending authorization sites, and devices.

The Dashboard is located under C-Site Management > Launch.

.

  

NOTE
Not all users will have access to all these features. Feature access will depend on a user’s 
permissions. See the User Role and Users sections for more information. 
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Policy Management Menu
This section provides an overview of how to edit policies on the Policy Management page. 

Edit Policy Management Menu

1. Log into the Verifone C-Site Management application.

2. Navigate to C-Site Management > Configuration > Policy Management.  

3. Select Policy. History lists the past actions for the Policy Management form. See the next section on 
History.

4. Search for the policy by Policy Type, Display Name, or Configuration Name. 

  

NOTE
Currently, the only two Policy Types are Mobile MOP and DCR Loyalty Manual Entry and 
they are predefined. 
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5. In the Policy Management list, click on a Policy to enable or disable it from an assigned site. 

6. Enable or disable the policy that is to be assigned or unassigned to the site(s).

  

NOTE For these steps, we will use the Mobile MOP policy. All policies have a similar form. 

  

NOTE The other fields are non-editable.
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7. Click on Assign. 

8. From the drop-down menu, add check mark(s) to the boxes next to the sites to be assigned to the 
policy.

9. Click on Apply Changes or Discard to remove changes. 
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10. Click on Unassign. 

11. From the drop-down menu, add check mark(s) to the boxes next to the sites to be assigned to the 
policy.

12. Click on Apply Changes or Discard to remove changes. 
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Policy Management History

The Policy Management History lists the Policy Type, Display Name, Admin Name, Date, Operation, and 
Status.  

Field Description

Policy Type It is the field in the dataset that is controlled by the Major Oil Policy. 

Display Name It is the name of the policy displayed to the user.

Admin Name It is the name of the administrator making the changes.

Date It is when the policy was assigned to the site. 

Status It displays if the assigned policy was completed. 
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Click on the Policy Type for more details and then proceed to the next section.
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Policy Type History

The Policy Management History for the Policy Type lists the Site Name, Service ID, Connection Status, 
Status, and Reason.   

Field Description

Service ID It is a number assigned by Verifone to a site.

Site Name It is the name of the site.

Connection Status It lists the sites that are offline, online, or pending.

Status It displays the status when the policy was assigned to the site. 

Reason It displays the meaning for the status. 

Download Report It gives an option to download a status report for all sites for the Policy Type in CSV format. 
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16 EXTERNAL ACCESS APPROVAL

The External Access Menu contains Verifone Authorized Service Contractor (VASC) Site Management and 
Partner Site Management. A Petro Site Administrator can now assign or unassign a site and features to or 
from a VASC or Partner company. This feature allows Verifone Commanders at those sites to be onboarded 
with VASC credentials. 

VASC Site Management
To assign or remove a VASC Company, navigate to the top menu on Verifone C-Site Management and 
select Administration > External Access and click on VASC Site Management.  

Use the search boxes to display the Service ID, Site Name, Connection Status, or VASC Company.

  

NOTE    Only the site administrator can assign VASC companies. 
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Click on Manage Sites. 

Field Description

Service ID It is a number assigned by Verifone to a site.

Site Name It is the name of the site.

Connection Status It lists the sites that are offline, online, or pending.

VASC Company It lists the Verifone Authorized Service Contractor (VASC) company. 
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Manage Sites

Assign Sites

1. Select Assign Sites. 

2. Select a VASC from the drop-down menu.
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3. Add check mark(s) to the boxes next to the sites to be assigned to the VASC.

4. Read the agreement and then add a check mark agreeing to the terms and conditions displayed on the 
form.

5. Click Assign and a message displays the quantity of sites assigned to the VASC. 

6. Click Close. 
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Unassign Sites

1. Select Unassign Sites. 

2. Select a VASC from the drop-down menu.
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3. Add check mark(s) to the boxes next to the sites to be unassigned from the VASC.

4. Read the agreement and then add a check mark understanding the terms and conditions displayed on 
the form.

5. Click Unassign and a message displays the quantity of sites unassigned from the VASC. 

6. Click Close.
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Partner Site Management
To assign or remove a Partner Company, navigate to the top menu on Verifone C-Site Management and 
select Administration > External Access and click on Partner Site Management.   

Use the search boxes to display the Service ID, Site Name, Connection Status, or VASC Company.

  

NOTE    Only the site administrator can assign Partner companies. 
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Click on Manage Sites. 

Field Description

Service ID It is a number assigned by Verifone to a site.

Site Name It is the name of the site.

Connection Status It lists the sites that are offline, online, or pending. 

Partner Company It lists the Partner company. 
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Manage Sites

Assign Sites

1. Select Assign Sites. 

2. Select a Partner from the drop-down menu.
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3. Add check mark(s) to the boxes next to the sites to be assigned to the Partner.

4. Read the agreement and then add a check mark agreeing to the terms and conditions displayed on the 
form.

5. Click Assign and a message displays the quantity of sites assigned to the Partner. 

6. Click Close. 
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Unassign Sites

1. Select Unassign Sites. 

2. Select a Partner from the drop-down menu.
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3. Add check mark(s) to the boxes next to the sites to be unassigned from the Partner.

4. Read the agreement and then add a check mark understanding the terms and conditions displayed on 
the form.

5. Click Unassign and a message displays the quantity of sites unassigned from the Partner. 

6. Click Close.
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Manage Features

Assign Features

1. Select Assign Features. 

2. Select a Partner from the drop-down menu.
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3. Add check mark(s) to the boxes next to the sites to be assigned to the Partner.

4. Add a check mark to the Feature to be assigned to the site for the Partner.

5. Click Assign and a message displays the feature assigned to a number of sites for the Partner. 

6. Click Close. 
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Unassign Features

1. Select Unassign Features. 

2. Select a Partner from the drop-down menu.
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3. Add check mark(s) to the boxes next to the sites to be unassigned from the Partner.

4. Add a check mark to the Feature to be unassigned from the site(s) from the Partner.

5. Click Unassign and a message displays the feature unassigned from a number of sites from the Partner.

6. Click Close.
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17 VASC ACCESS

The VASC company should email Training@Verifone.com to establish an initial VASC admin account unless 
one has already been created. Afterwards, the VASC can perform limited tasks and onboarding.

Website URL 
To access Verifone C-Site Management, navigate to the following URL using a web browser:

https://us.live.verifone.cloud/
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VASC Welcome Page
After the VASC logs in, the Welcome Page Displays. 

  

NOTE Currently, the C-Site Management Dashboard > Launch has not been implemented.
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Hierarchy Menu
This section provides an overview of how to edit and manipulate hierarchies on the Merchant 
Administration page. A hierarchy structure allows the building or mapping of the business structure within 
Verifone C-Site Management. Hierarchies should be configured before adding sites to Verifone C-Site 
Management.

Hierarchy Menu

Navigate to Administration > Site Management > Hierarchy. 

View Hierarchy

1. Log into the Verifone C-Site Management application.

2. Click on Administration > Site Management > Hierarchy. 

3. Use the Search bar to search for the name or use the collapsible menu below the search bar.
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Edit Hierarchy

1. Hierarchies can be edited by selected the Edit Hierarchy button in the top right corner of the Hierarchy 
window.

2. The following icons, if available, will appear next to the hierarchy names. Not all icons will appear next to 
each name based on the available functions for that row.

  

NOTE If a new VASC Administrator has not set up any hierarchy for the account, the display page 
will show the company name with any sub-entries all in one group.
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Icon Description

Edits an existing groups name.

Adds a sub-group to an existing group.

Reorders icons by selecting the group to move from the list, and then dragging and dropping the 
group.

Adds a new group to the highlighted row. The new group name prompt will appear below this line 
when selecting this icon. 

Deletes a group
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Search Hierarchy

Key in the name of the group in the search field to narrow down the hierarchy to the entered characters.
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Sites Menu
1. Log into the Verifone C-Site Management application.

2. Click on Administration > Site Management > Sites. 

3. Use the Search bar to search for the Service ID, Site Name, or scroll through pages.

4. Click on a site to view the Site Details, Custom Attributes, or Hierarchy.
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Site Details

View the site details and see the table below for descriptions.

Field Definition

Service ID* The Verifone Service ID shown in the site’s contract with Verifone.

Site ID Any ID number used by the organization operating the site.

Site Name The name of the site. This is useful when searching for sites. You must enter a site name.
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Street Address The physical address of the site.

Country Choose a state from the drop-down list.

State Choose a state from the drop-down list.

City The municipality in which the site is located (or equivalent).

Zip Code The ZIP code for the site.

Phone The phone number for the site.

Field Definition
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Custom Attributes

Custom attributes allow users to search for sites based on specific criteria relevant to those sites, such as 
brand of fuel sold, software version on the site controller, type of installation, etc. Up to five attributes can 
be added per site.

1. Select the Custom Attributes within the Site Details form.

2. Select +Create New.

3. Enter the name for the attribute in the field that appears.

4. Enter a value in the field provided.

5. To delete an attribute, select the Trash can icon.
                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         242



                                                                                                                                Verifone C-Site Management User Guide
 

Hierarchy

Use this section to re-assign a site to another group. 

1. Select the Hierarchy within the Site Details form.

2. Search for the new VASC group by name.

3. Click on the VASC group and then click on the Re-assign to this group button.

4. Click Save Changes or Cancel.
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Users Menu

 

Search for a User
1. To search for a user, navigate to Administration > User Management > Users. 

2. Search by name, created date, or filter.

  

NOTE
Before creating users, Hierarchies and Sites must already be configured.        
                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         244



                                                                                                                                Verifone C-Site Management User Guide
 

Add User
1. To create new users, navigate to Administration > User Management > Users. 

2. Click Add User in the top right corner of the screen. Complete the required fields using the table below 
for reference. 

Field Description

Name Enter in the name of the VASC. It is recommended to use the First and Last name in the name field. 

Email Enter in the email address for the VASC. It is recommended to use company email addresses when 
possible. The email address is used for logging into the Verifone C-Site application.
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Deleting a User
1. To delete users, navigate to Administration > User Management > Users. 

2. Select the user from the list. 

3. Select Delete User on the bottom left corner of the User Detail screen. To utilize the same email 
address, the Verifone Helpdesk must be contacted to fully remove the users email address.

Status VASCs can be set to active or deactivated if they no longer need access to the Verifone C-Site 
Management Application.

Technician ID Enter the ID for the VASC. 

Role Assign the role from the list that best fits the VASC’s job functions. 

Site Assignments VASCs can be assigned to specific hierarchies, meaning they can be permitted access to only a 
subset of sites. If the VASC requires access to all sites, then select the first option under site 
assignments which will select all locations.

Create User Click to create the user (VASC). 

Discard Click to discard all entries on the current form. 
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18 PARTNER ACCESS

The Partner company should work with Partner team to establish a Partner admin account. Afterwards, the 
Partner can perform limited tasks.

Website URL 
To access Verifone C-Site Management, navigate to the following URL using a web browser:

https://us.live.verifone.cloud/
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Partner Welcome Page
After the Partner logs in, the Welcome Page displays. 

  

NOTE Currently, the C-Site Management Dashboard > Launch has not been implemented.
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Hierarchy Menu
This section provides an overview of how to edit and manipulate hierarchies on the Merchant 
Administration page. A hierarchy structure allows the building or mapping of the business structure within 
Verifone C-Site Management. Hierarchies should be configured before adding sites to Verifone C-Site 
Management.

Hierarchy Menu

Navigate to Administration > Site Management > Hierarchy. 

View Hierarchy

1. Log into the Verifone C-Site Management application.

2. Click on Administration > Site Management > Hierarchy. 

3. Use the Search bar to search for the name or use the collapsible menu below the search bar.
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Edit Hierarchy

1. Hierarchies can be edited by selected the Edit Hierarchy button in the top right corner of the Hierarchy 
window.

2. The following icons will appear, if available, next to the hierarchy names. Not all icons will appear next to 
each name based on the available functions for that row.

  

NOTE If a new Merchant Administrator has not set up any hierarchy for the account, the display 
page will show the company name with any sub-entries all in one group.

Icon Description

Edits an existing groups name.

Adds a sub-group to an existing group.
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Reorders icons by selecting the group to move from the list, and then dragging and dropping the 
group.

Adds a new group to the highlighted row. The new group name prompt will appear below this line 
when selecting this icon. 

Deletes a group

Icon Description
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Search Hierarchy

Key in the name of the group in the search field to narrow down the hierarchy to the entered characters.
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Sites Menu
1. Log into the Verifone C-Site Management application.

2. Click on Administration > Site Management > Sites. 

3. Use the Search bar to search for the Service ID, Site Name, or scroll through pages.

4. Click on a site to view the Site Details, Custom Attributes, or Hierarchy.
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Site Details

View the site details or edit the Site ID. See the table below for descriptions.

Field Definition

Service ID* The Verifone Service ID shown in the site’s contract with Verifone.

Site ID Any ID number used by the organization operating the site. It is the only value that can be 
edited.

Site Name The name of the site. This is useful when searching for sites. You must enter a site name.

Street Address The physical address of the site.

Country Choose a state from the drop-down list.
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State Choose a state from the drop-down list.

City The municipality in which the site is located (or equivalent).

Zip Code The ZIP code for the site.

Phone The phone number for the site.

Save Changes Click to save Changes.

Discard Click to discard changes on the current form. 

Field Definition
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Custom Attributes

Custom attributes allow users to search for sites based on specific criteria relevant to those sites, such as 
brand of fuel sold, software version on the site controller, type of installation, etc. Up to five attributes can 
be added per site.

1. Select the Custom Attributes within the Site Details form.

2. Select +Create New.

3. Enter the name for the attribute in the field that appears.

4. Enter a value in the field provided.

5. To delete an attribute, select the Trash can icon.
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Hierarchy

Use this section to re-assign a site to another group. 

1. Select the Hierarchy within the Site Details form.

2. Search for the new Partner group by name.

3. Click on the Partner group and then click on the Re-assign to this group button.

4. Click Save Changes or Cancel.
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API Keys
A Partner will need an Application Programming Interface (API) Key and the User ID in order to use the 
Verifone C-Site Management APIs. Use the following steps to obtain the API Key and User ID. 

1. Navigate to the Partner Welcome page and click on the profile icon in the upper right-hand corner of the 
screen. 

2. Click on API Keys.

3. Click on Create API Key. 
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4. Click on Copy public key or Discard. 

  

NOTE The maximum allowed keys is five. An unused key can be revoked by clicking on the API key 
and then clicking on the Revoke Access button from the panel on the right side of the 
screen.

  

NOTE The API key can only be copied once. Store the API key in a safe place. If the key is lost, the 
key should be deactivated and a new one should be created. 
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5. Click on the newly created API Key to obtain the User ID. 
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6. Click on Copy button and paste the User ID to a same place as the API Key.  
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Revoke Access

1. Click on the API Key to delete or revoke the access.

 

                                                                      Proprietary + Confidential. © Verifone Inc. All rights reserved.                                                         262



                                                                                                                                Verifone C-Site Management User Guide
 

2. Click on Revoke Access to delete the API Key.
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19 VIPER TABLE MANAGEMENT

Viper Table Set Management is intended to perform scheduled updates to the card tables in the Verifone 
Commander. Table updates are XML formatted and must be specifically formatted to ensure no errors 
occur. 

Updates should not be performed without assistance from Verifone at this time.

  

CAUTION

Updates should not be performed without assistance from Verifone at this time.       
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20 CONNECT DEVICE TO CLOUD

The Connect Device to Cloud section will provide details on how to enable the Cloud Connect feature in 
Verifone Configuration Client. Each Verifone Commander must be onboarded to the cloud within Verifone 
Configuration Client and added to Verifone C-Site Management.

Requirements
• The site where the device is located is set up within Verifone C-Site Management within 

Administration > Sites.

• The Verifone Commander onboarder must have credentials for Verifone C-Site Management.

• DNS must be enabled within Verifone Configuration Client (Local Area Network Configuration) for 
the connection to be successful. 

  

NOTE

If the site's information was not added to Verifone C-Site Management prior to completing 
the Verifone Configuration Client onboarding steps, the site will automatically be added to 
Sites within Verifone C-Site Management. 
The site name will be the site's service ID and the hierarchy will need to be modified.
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Pre-Release 54.02 - Connecting Device to Verifone C-Site Management
Ensure that the instructions are followed for the correct 
software release installed on the Verifone Commander prior to 
beginning onboarding. To begin the process of attaching the 
Verifone Commander to the cloud:

1. Log in as Manager in Verifone Configuration Client and 
navigate to Initial Setup > Cloud Connect.

2. Select the Cloud Connect button from the screen.
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3. A URL and a user code is generated. Copy the User Code that was generated on your Configuration 
Client and then select the URL on your screen. 

4. After the URL opens, enter the user code from Configuration Client into the ‘Enter your code here’ field 
and click Submit.
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5. Click Yes, log into the new site. A page will open that will prompt you to log into C-Site Management.

6. Login with the credentials for Verifone C-Site Management.

7. The next prompt will prompt you to allow sharing the information from the Verifone Commander. Select 
Allow. A message will display ‘DONE!’.

8. Return to the Configuration Client page. Select Confirm Verification from the Cloud Connect window.
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9. The Cloud Connect window will display ‘Registration completed on (Date / Time)’.

  

NOTE There is a 5-minute delay from when the site will show Active within Verifone C-Site 
Management after it is registered.        

 

WARNING
If DNS is not enabled in Configuration Client > Initial Setup > Local Area Network 
Connection, then the Verifone Commander will not be able to resolve the IP from 
the URL and onboarding will fail.
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Troubleshooting 

Error response ‘User Code has Expired. Please star the registration again.’

• Make sure the user trying to onboard the Verifone Commander has the ‘Commander Onboarder 
Role’ assigned within Verifone C-Site. If the role has been assigned to the user, then contact the 
Verifone Helpdesk. The expiration time for the user code is 14 minutes, but the role assignment issue 
will appear immediately.

Error response ‘Communication error, please check network settings.’

1. For the following payment networks, no routes need to be added into Initial setup > LAN Configuration 
as the MNSP will make the changes needed: BP, Sunoco, and Chevron*. Chevron is making the changes 
to the MNSP with the assumption that the Payment NIC is configured for the default route. If the 
Payment NIC is not the default route, then it needs to be changed to the default route, saved, and the 
Verifone Commander must be rebooted. See the Chevron Playbook for more details. 

2.  For Shell, Generic Buypass, etc. where the Payment NIC is NOT the default route, then DNS routes are 
required. DNS 1 8.8.8.8 and DNS 2 8.8.4.4 – Unless other DNS routes are required by the site’s network 
administrator. 

3. Site such as Exxon, Generic Buypass (Gulf, Sinclair, etc.) and others who do not have their own IP 
scheme and has the Payment NIC set as the default route would need to add the following Host Routes 
and DNS settings into Initial Setup > LAN Configuration:
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Host Routes

DNS Settings

• DNS 1: 8.8.8.8

• DNS 2: 8.8.4.4

Host Route 
Description

IP Address Gateway Subnet 

C-Site VAM 1 23.23.135.174 192.168.31.31 255.255.255.255

C-Site VAM 2 18.213.229.217 192.168.31.31 255.255.255.255

C-Site VIC 1 34.117.16.222 192.168.31.31 255.255.255.255

C-Site GSC 1 184.72.129.214         192.168.31.31 255.255.255.255

C-Site GSC 2 54.221.203.197          192.168.31.31 255.255.255.255

C-Site GSC 3 52.72.155.235            192.168.31.31 255.255.255.255

C-Site MQTT 1 184.73.231.196      192.168.31.31 255.255.255.255

C-Site MQTT 2 3.212.149.223         192.168.31.31 255.255.255.255

C-Site MQTT3 52.6.28.56                192.168.31.31 255.255.255.255

DNS 1 8.8.8.8                                      192.168.31.31 255.255.255.255

DNS 2 8.8.4.4                                      192.168.31.31 255.255.255.255
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Release 54.02+ - Connecting Device to Verifone C-Site Management
In Verifone Commander software release 54.02 and higher, there have been enhancements made to 
onboard the Verifone Commander. The steps have been simplified from previous releases. 

Ensure that the instructions are followed for the correct 
software release installed on the Verifone Commander 
prior to beginning onboarding.

1. Log into Configuration Client and navigate to Initial 
Setup > Connect to Verifone C-Site Management.

2. Enter in the C-Site Email and Password to connect the Verifone Commander to C-Site. Do not use the 
Configuration Client Credentials – they will not work. If the site doesn’t have an account, selecting the 
‘Don’t have an account?’ option will provide information for the site to sign up for Verifone C-Site 
Management.

3. When the correct crednetials are entered in, Configuration Client will display ‘Connecting to Verifone C-
Site Management in Progress’. 
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4. After the onboarding is complete, then below message will be displayed. 

Troubleshooting

Error message ‘Invalid credentials, please try again. Please make sure you are using your C-Site credentials 
to login’: 

• Confirm the Verifone C-Site Credentials are being used and not the Verifone Configuration Client 
Credentials. 

Error message ‘Wrong Serial Number – Service ID Mapping. Please contact helpdesk’: 

• The service ID may be incorrect in the Verifone Commander. Confirm the site’s service ID is entered 
in by navigating to Help > Support in Configuration client to verify it is correct. If the service ID 
entered is incorrect, contact the Verifone helpdesk to correct the service ID. 

• Verifone Commander serial number may not match what the site has registered. Reach out to the 
Verifone Helpdesk to correct the Verifone Commander Serial number and/or Service ID.
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21 ONE-TIME PASSWORD

The One-Time Password feature allows a one-time password (OTP) for a site’s Verifone Commander to be 
sent to an email address. An OTP may be required to make changes to specific areas within Verifone 
Configuration Client, such as Manage Users. However, the OTP is only displayed locally on the Verifone 
Commander or Verifone POS. 

Requirements
• A valid account with Verifone C-Site Management

• An active site, onboarded with Verifone C-Site Management

• Verifone Software Release 53.35+

• An active email associate with Verifone C-Site Management

• Manager access to Verifone Configuration Client.

Configuring OTP Emails
1. Log in to the Verifone C-Site Management application. In the top right corner of the application, select 

your account profile icon and select OTP Settings.
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2. If the Send OTP check box is not selected, click on Edit to enable the parameter. Save the changes if 
they have been made.

3. Login to Verifone Configuration Client and go to Security > Manage Users. Enter in the OTP when 
prompted.

  

NOTE
The email address cannot be changed as it is the User ID.       
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4. Enter in the Verifone C-Site Management email address (the same one as used in the OTP settings) in 
the User ID Field. Select Save on the User administration form.

  

NOTE As mentioned above in the Requirements section, Verifone Configuration Client users must 
have a Verifone C-Site Management user ID to receive OTPs by email.      
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Using the OTP to Email Feature
1. Any areas of Configuration Client that require an OTP will prompt for a One Time Password (as shown 

below). Select Generate OTP to the right of the entry field. The OTP will be sent to the email configured.

2. Check the email to retrieve the OTP and enter the prompt on Configuration Client.
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A   APPENDIX

Verifone Commander Release 53.41

  

NOTE Self-checkout end users will not see prompting messages. Messages will only appear 
when accessing cashier screens.       

Topic
When will 
this appear

Frequency
Feature 
Disablement

Messages Resolution

Verifone 
Commander 

not 

onboarded

120 days 
post 

installation of 

the Verifone 
Commander 

Software

Appears at 
login

N/A Onboard the Verifone 

Commander
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Verifone 

Commander 
Onboarded, 

but ASM 

Expired

120 days 

post 
installation of 

the Verifone 

Commander 
Software

Every 

Transaction

N/A Renew ASM License

Not 

Connected

Any time 

after 
Onboarding

When 

connectivity 
is lost to 

C-Site. 

Appears at 
POS Login.

N/A 1. Work with your 

MNSP to confirm 

connectivity to 

Verifone C-Site is 

maintained.

2. Contact the 

helpdesk for 

assistance. 
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Verifone Commander Release 54.00 and 54.01

Topic
When will 
this appear

Frequency
Feature 
Disablement

Messages Resolution

Verifone 

Commander 
not 

onboarded

60 days post 

installation of 
the Verifone 

Commander 

Software

Every 

transaction

Forecourt 

and POS 
functionality

Disablement 

occurs at 90 

days for 
Forecourt 

and 91 days 
for the POS. 

Occurs at 
midnight 
when the 
system is 
idle.

Onboard the Verifone 

Commander

Verifone 
Commander 

Onboarded, 

but ASM 
Expired

60 days post 
installation of 

the Verifone 

Commander 
Software

Every 
Transaction

Forecourt 
and POS 

functionality

Disablement 
occurs at 90 

days for 

Forecourt 
and 91 days 

for the POS. 

Occurs at 
midnight 
when the 
system is 
idle.

Renew ASM License
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Verifone Commander Release 54.02

Not 

Connected

Anytime after 

Onboarding

N/A 1. Work with your 

MNSP to confirm 
connectivity to 

Verifone C-Site is 

maintained.

2. Contact the 
helpdesk for 

assistance. 

Topic
When will 
this appear

Frequency
Feature 
Disablement

Messages Resolution

Verifone 

Commander 
not 

onboarded

60 days post 

installation of 
the Verifone 

Commander 

Software

Every 

transaction

Forecourt 

and POS 

functionality

Disablement 

occurs at 90 

days for 

Payment 

(inside), Self-

Checkout, 

and 

Forecourt. 

POS is 

disabled at 91 

days. Occurs 

at midnight 

when the 

system is 

idle.

Onboard the 

Verifone 

Commander
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Verifone 

Commander 
Onboarded, 

but ASM 

Expired

60 days post 

installation of 
the Verifone 

Commander 

Software

Every 

Transaction

Forecourt 

and POS 

functionality

Disablement 

occurs at 90 

days for 

Payment 

(inside), Self-

Checkout, 

and 

Forecourt. 

POS is 

disabled at 91 

days. Occurs 

at midnight 

when the 

system is 

idle.

Renew ASM 

License

Not 

Connected

Anytime after 

Onboarding

N/A 1. Work with your 

MNSP to confirm 

connectivity to 

Verifone C-Site is 

maintained.

2. Contact the 

helpdesk for 

assistance. 
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Verifone

University Drive
Coral Springs,

FL 33065, USA

Fax: 4545 233

Phone: 001 454 2333

www.verifone.com

Thank you!

We are the payments architects who truly understand 
commerce.
As payment architects we shape ecosystems for online and in-person 
commerce experiences, including all the tools you need… from gateways 
and acquiring to fraud management, tokenization, and reporting.

As commerce experts, we are here for you and your business. With our 
payment devices, our systems & solutions and our support. Everywhere. 
Anytime. So that your customers feel enabled, recognized and well taken 
care of, even beyond their expectations.

Verifone. Creating omni-commerce solutions that simply shape powerful 
customer experiences.
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